crash shutting down mail/news app core after sending msg

VERIFIED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED WORKSFORME
19 years ago
13 years ago

People

(Reporter: Akkana Peck, Assigned: Jean-Francois Ducarroz)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: no status)

(Reporter)

Description

19 years ago
Run apprunner -mail.  Click New Msg.  Type in a to address and some text, and
send the message. Dismiss the compose window (with the windowmanager dismiss "X"
in the corner of the window).  Now File->Exit from the mailnews window.  Get a
crash:

#2  0x4001dcdb in nsAppShellService::Shutdown (this=0x807d838)
    at /builds/mon/mozilla/xpfe/appshell/src/nsAppShellService.cpp:407
#3  0x4097127f in nsMsgAppCore::Exit (this=0x87bb558)
    at /builds/mon/mozilla/mailnews/base/src/nsMsgAppCore.cpp:755
#4  0x40972a20 in MsgAppCoreExit (cx=0x8578cb0, obj=0x8475890, argc=0,
    argv=0x85fd634, rval=0xbfffe2e4)
    at /builds/mon/mozilla/mailnews/base/src/nsJSMsgAppCore.cpp:485
#5  0x4040192b in js_Invoke (cx=0x8578cb0, argc=0, constructing=0)
    at /builds/mon/mozilla/js/src/jsinterp.c:650

Looks like the crashes we were seeing from the editor when we were leaking the
pres shell.

Comment 1

19 years ago
I'm not seeing that crash in the 5_19 build: gdb shows "Program exited normally"
when I exit it.

When I dismiss the compose window with the window manager X, though, I do see
Gtk-CRITICAL **: file gtkwidget.c: line 1394 (gtk_widget_destroy): assertion
`widget != NULL' failed.

Gtk-CRITICAL **: file gtkwidget.c: line 1394 (gtk_widget_destroy): assertion
`widget != NULL' failed.

Could that be relevant?

The 5_19 build is wierd anyway, though...we can't display messages, for one
thing, so I'll retest tomorrow's build.

Comment 2

19 years ago
FWIW, the 5_17 build shows those same two lines at that place...the 5_14 build
simply shows
"Closing compose app core
Closing editor app core
composeAppCore.exit() not yet implemented!"

Updated

19 years ago
Assignee: phil → ducarroz
Target Milestone: M6

Comment 3

19 years ago
Reassign to ducarroz for M6

Updated

19 years ago
Whiteboard: no status

Comment 4

19 years ago
Using 19990524 m6 builds on linux, mac and win32 I can't reproduce this.  Akkana
is this still happening to you?
(Assignee)

Comment 5

19 years ago
I cannot reproduce this problem either on My Mac or on Windws with last Friday's
build.
Status: NEW → ASSIGNED
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 6

19 years ago
I cannot reproduce this problem either on My Mac or on Windws with last Friday's
build.
(Assignee)

Comment 7

19 years ago
Mark it as Work for me.

Comment 8

19 years ago
Akkana, before I mark this verified as worksforme, are you seeing this problem
any longer?  Thanks.
(Reporter)

Comment 9

19 years ago
Doesn't seem to happen on Linux, either, as of 5/24 build.

Updated

19 years ago
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.