Mozilla disable the BACK and FORWARD buttons on pages with frames

VERIFIED DUPLICATE of bug 56062

Status

()

VERIFIED DUPLICATE of bug 56062
18 years ago
11 years ago

People

(Reporter: ljpp, Assigned: radha)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME, URL)

(Reporter)

Description

18 years ago
This kind of behaviour makes no sense, since not all pages have proper
navigation menus. BACK & FORWARD buttons should function normally, with or
without frames

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010127

Comment 1

18 years ago
Dup of the numerous Back/Forward doesn't work in frames bugs.
Reporter : please post a real url in the url field. "Any url with frames"
doesn't help, we are lazy.
Thanks.
->History:session
Assignee: asa → radha
Severity: enhancement → normal
Component: Browser-General → History: Session
QA Contact: doronr → claudius
Reporter, these back and forward bugs are being fixed all the time.  Please make
sure you are using a recent build, post your build ID, and post a page on which
you can reproduce the problem 100% of the time (or at least often), together
with steps to reproduce.

Does the problem happen when the frameset is the first page loaded in the
browser?  Or anytime?  These details matter.

Thanks for reporting bugs, and taking the time to help us figure out what's
going on here.
Whiteboard: DUPEME
(Reporter)

Comment 3

18 years ago
BACK and FORW buttons are disabled on all pages with frames. 

BUILD ID: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) Gecko/20010127

Fixing typo in URL field.

Lasse, when I go to the page in question the back and forward buttons work fine
for me (linux build 2001-01-29-08).  Now this could be a windows-specific
problem, or you and I could be doing slightly different things.  Could you
possibly post a step-by-step list of what you do from the moment you start the
browser to the moment when you hit the back (or forward) button and discover
that it does not work?  That would be immensely helpful in fixing this bug.

Comment 5

18 years ago
back/forward buttons wfm in a framest using 2001013004 win98
(except if first page loaded is a frameset but that's covered by bug 56062)
(Reporter)

Comment 6

18 years ago
Steps to reproduce:

-Boot to Windows 2000
-Open Internet connection
-Start Mozilla Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; m18) 
Gecko/20010127
- Enter a URL with frame (example www.r3mix.net)
- BACK & FORM buttons are disabled

I haven't tried with newer builds yet.
Lasse, it sounds like a duplicate of bug 56062.  Could you please take a look at
that one and see whether what you are seeing is the same thing?
(Reporter)

Comment 8

18 years ago
Confirmed as a dublicate of bug 56062


*** This bug has been marked as a duplicate of 56062 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
verified duplicate
Status: RESOLVED → VERIFIED

Updated

11 years ago
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.