Last Comment Bug 670329 - Avoid bumping arm target because of neon code
: Avoid bumping arm target because of neon code
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: ARM Linux
: -- normal (vote)
: mozilla8
Assigned To: Mike Hommey [:glandium]
:
: Milan Sreckovic [:milan]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-09 02:03 PDT by Mike Hommey [:glandium]
Modified: 2011-07-15 07:11 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Avoid bumping ARM target because of NEON code in gfx (1.81 KB, patch)
2011-07-09 02:05 PDT, Mike Hommey [:glandium]
jmuizelaar: review+
Details | Diff | Splinter Review

Description Mike Hommey [:glandium] 2011-07-09 02:03:36 PDT
We need some binary target correctness: each object file is marked with the target it was built for, and when linking, ld marks the final binary with the greater target it found on the way. With the hacks to allow building unsupported instructions on the target used by the compiler, the resulting objects end up having a bumped target, thus bumping the final binary (libxul) target, which is not expected. Using .object_arch forces the target to be downsized for the given object file, but doesn't affect the final binary target, since other object files are still targeted at whatever target is used by the compiler.
Comment 1 Mike Hommey [:glandium] 2011-07-09 02:05:44 PDT
Created attachment 544967 [details] [diff] [review]
Avoid bumping ARM target because of NEON code in gfx

(Not convinced you are the right reviewer for this)
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-07-14 07:25:47 PDT
Comment on attachment 544967 [details] [diff] [review]
Avoid bumping ARM target because of NEON code in gfx

Do we need something like this for pixman as well?
Comment 3 Mike Hommey [:glandium] 2011-07-14 08:16:03 PDT
pixman already has something like this.

Note You need to log in before you can comment on or make changes to this bug.