Random crashes without a stack trace

RESOLVED INVALID

Status

()

Firefox
General
RESOLVED INVALID
7 years ago
5 years ago

People

(Reporter: Thomas B. Rücker [account mostly dormant], Unassigned)

Tracking

5 Branch
All
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Reproducing this is not straight forward. I have one profile where this happens totally at random and another where I have a 100% chance of crash 5min after starting firefox (that's about the time it takes to restore the session of 30-50 tabs plus some time to settle).
On the latter profile it gets reduced to random crashes if I go into safe mode with gpu acceleration disabled (just disabling extensions does not help):

Graphics
Adapter Description  Intel(R) HD 
GraphicsVendor ID  8086
Device ID  0046
Adapter RAM  Unknown
Adapter Drivers  igdumdx32 igd10umd32
Driver Version  8.15.10.2361
Driver Date  4-10-2011
Direct2D Enabled  false
DirectWrite Enabled  false (6.1.7601.17563, font cache n/a)
WebGL Renderer   Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.611)
GPU Accelerated Windows  0/1

My best guess right now is that there are actually two bugs but both don't produce a stack trace for some reason.

Example crashes:
bp-05ef17c6-e087-4124-b6ea-525b32110709
bp-e881c45f-216b-4b2b-b3a0-cf7702110709
bp-4521dde9-9f37-4587-839c-2a6242110707
bp-c202f024-e124-4974-a865-0a7ed2110702
bp-e6fd2264-4013-41b8-b155-fb1c92110621
bp-0bdf9725-ae7a-4a7e-8592-6dc7e2110619
bp-928d01e6-eb2b-4457-bd76-0e67a2110619
bp-3ddfd621-2f6e-4c1b-8569-c83f02110619
bp-e52e1ccd-843c-46a7-a86b-c5e832110619
bp-883da76c-ce36-4d7e-9d2f-b687c2110619
bp-60552263-91f2-4cb9-a40d-33f112110619
bp-ded72423-df95-4a24-b6e8-21f3c2110619
bp-b185a9ca-ee26-4e55-b480-012aa2110619
bp-4b23953d-999a-433b-ac63-372ee2110619
bp-20ce9519-4191-4910-a0a2-7fd9b2110619
There's older ones if you want too. Started happening when I switched to 4.0 IIRC.


Actual results:

Browser crashes. Crash reporter appears.


Expected results:

Browser continues to work.
Maybe you can get a useful Stack using WinDbg?
https://developer.mozilla.org/en/How_to_get_a_stacktrace_with_WinDbg
OS: Other → Windows 7
Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110816 Firefox/8.0a1

I could not reproduce this issue.
Could you be more specific in the steps you took to encounter this crashes?
Try starting Firefox on a new prof
http://support.mozilla.com/en-US/kb/Managing-profilesile:
Try starting Firefox in safe mode:
http://support.mozilla.com/en-US/kb/Safe%20Mode
Post a comment if it still occurs!
Thanks!
Seems this is an out of memory condition of some sort under Windows.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.