Closed Bug 670435 Opened 9 years ago Closed 9 years ago

Recepient's username displayed as @[object Object] and top contributors list missing in Army of Awesome

Categories

(support.mozilla.org :: Army of Awesome, task, critical)

task
Not set
critical

Tracking

(Not tracked)

VERIFIED FIXED
2011-07-12

People

(Reporter: amlanmitra, Assigned: rrosario)

Details

When one tries to reply in Army of Awesome, the intended recipient's twitter ID is displayed as @[object Object] instead of the actual twitter ID. This prevents the reply from reaching the user and has completely stalled the service.

Also, the top contributors list is not being displayed on the right side panel.
Confirming, renders the service useless. This must have regressed very recently.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Would it be possible to have this fixed for the 7/12 milestone? Also, we may want to add a test to make sure this doesn't regress again in the future.
Severity: blocker → critical
Assignee: nobody → rrosario
Target Milestone: --- → 2011-07-12
Regression from fix for Bug 662474
Fixed on Master:
https://github.com/jsocol/kitsune/commit/933203b71f038df5f32a1ddab981c65594010019
and Next:
https://github.com/jsocol/kitsune/commit/93872dde9ac1cb67ae68c51a18c645cb875a707c

We should record replies with statsd to be able to see when they stop. I'll file if it isn't yet.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Also, the top contributors list data comes from metrics. If it doesn't start showing up once replies work again then we should file a new bug to investigate.
Bug 652623 is for graphing replies.
Since this is breaking the service, please do an emergency push as soon as possible.
Verified top contributors list displays after cron update, replies show username correctly.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.