Firefox hangs when downloading a file to a UNC path which is unavailable.

RESOLVED DUPLICATE of bug 349733

Status

()

Core
Networking: File
RESOLVED DUPLICATE of bug 349733
7 years ago
2 years ago

People

(Reporter: Shad Sterling, Unassigned)

Tracking

({hang})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [dupeme])

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0.1) Gecko/20100101 Firefox/4.0.1
Build ID: 20110413222027

Steps to reproduce:

My download path (Options | General | Save files to) is a UNC path to a Samba server (on OpenSUSE 11.3) which occasionally stops responding.  I attempted to download a file to my shared downloads folder using Firefox when the Samba server had stopped responding.



Actual results:

Firefox became unresponsive, and remained so for several minutes (after which I killed it).
Attempting to browse the same folder using Windows Explorer resulted in a long delay (a minute or so) followed by an error message.


Expected results:

Firefox should have given a similar error message after a similar amount of time.
(Reporter)

Updated

7 years ago
OS: Other → Windows XP
Hardware: All → x86

Comment 1

6 years ago
Shad do you stil see this when using a current version?

I'm pretty sure this is described in another bug report
Component: General → Untriaged
Flags: needinfo?(me)
Keywords: hang
Summary: Firefox crashes when downloading a file to a UNC path which is unavailable. → Firefox hangs when downloading a file to a UNC path which is unavailable.
Whiteboard: [dupeme]
(Reporter)

Comment 2

6 years ago
I no longer have a windows machine to test it on, and on the machines I do have I've reorganized my files so I download locally and sync with unison.  What's the other bug report you think describes this?
Flags: needinfo?(me)
Hi Shad, It's been a while since anyone looked at the issue and I'm not able to replicate it. I'd like to close the bug. If you come across a situation where you have more information, please re-open it and comment.  Thanks!
Component: Untriaged → Networking: File
Flags: needinfo?(me)
Product: Firefox → Core
Version: 3.6 Branch → unspecified
(Reporter)

Comment 4

3 years ago
I finally have a windows machine to test it on, but I can't tell what version of Firefox is running; there is no Help menu inside the ☰ menu.

Setting the Download folder to a UNC path works when the server is responding.  When the server isn't responding, this version of Firefox doesn't hang, but instead saves the file to the local downloads folder without giving the user any indication that it didn't do what was expected.

Comment 5

3 years ago
(In reply to Shad Sterling from comment #4)
> I finally have a windows machine to test it on, but I can't tell what
> version of Firefox is running; there is no Help menu inside the ☰ menu.

at the bottom of the menu click the question mark in the circle
(Reporter)

Comment 6

3 years ago
34.0.5, and downloading an update.  Having a footer on a menu of icons is confusing; I was looking for the question mark icon in with the rest of the icons (just like the help menu used to be in with the rest of the menus).
Flags: needinfo?(me)
(Reporter)

Comment 7

3 years ago
38.0.1 does the same thing as 34.0.5: downloads to the wrong path rather than notify the user.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 349733
You need to log in before you can comment on or make changes to this bug.