Vanishing document.constructor for Web Console

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
7 years ago
2 months ago

People

(Reporter: bj, Unassigned)

Tracking

8 Branch
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110709 Firefox/8.0a1
Build ID: 20110709030751

Steps to reproduce:

In the web console window I can create "Object Inspector" windows by typing "inspect(document)". Sometimes the windows list a constructor for the document, sometimes they don't. (See steps 3 and 6 below.)

I can create similar "Inspect:document" windows by typing "document" and clicking on "[object HTMLDocument]". These windows list a constructor when created, but it sometimes vanishes when update is clicked. (See steps 4, 5, and 8 below.)

Steps to demonstrate:

1. Create a blank tab.
2. Open Web Console.
3. Type "inspect(document)<enter>", and scroll down to look for "constuctor".
4. Type "document<enter>", click on "[object HTMLDocument]", and scroll down to look for "constuctor".
5. Update the "Inspect:document" window and look for "constructor".
6. Type "inspect(document)<enter>", and scroll down to look for "constuctor".
7. In the address bar type "mozilla.org<enter>".
8. Update the "Inspect:document" window and look for "constructor".
9. Type "document<enter>", click on "[object HTMLDocument]", and scroll down to look for "constuctor".
10. In the address bar type "mozilla.com<enter>".
11. Update the second "Inspect:document" window and look for "constructor".



Actual results:

3. "constructor" not present.
4. "constructor" present.
5. "constructor" still present.
6. "constructor" present.
8. "constructor" vanishes.
9. "constructor" present.
11. "constructor" vanishes.


Expected results:

All "Object Inspector" and "Inspect:document" windows list "constructor".
Nice one!
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 2

7 years ago
sounds similar to bug 651501
Yes, I've reproduced it (albeit intermittently), too. Not sure what's going on, though.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 697300

Comment 5

7 years ago
Dave, are you positive the bug was duped correctly?

Comment 6

7 years ago
Nope.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I don't know what this is but it hasn't been mentioned in awhile.
Component: Developer Tools → Developer Tools: Console
(Reporter)

Comment 8

6 years ago
I am unable to reproduce this issue any more.
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago6 years ago
Resolution: --- → WORKSFORME

Updated

2 months ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.