The default bug view has changed. See this FAQ.

XUL: Document the disableonsend attribute

REOPENED
Unassigned

Status

Developer Documentation
Mozilla Platform
REOPENED
6 years ago
4 months ago

People

(Reporter: tessarakt, Unassigned, Mentored)

Tracking

({helpwanted})

Details

(Whiteboard: [good first bug][lang=html])

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110709 Firefox/7.0a2
Build ID: 20110709042004

Steps to reproduce:

I was looking for documentation of the "disableonsend" attribute, which occured in addon code I am currently having a closer look at.



Actual results:

There is such documentation on MDN. Nothing found via Google, no page at https://developer.mozilla.org/en/XUL/Attribute/disableonsend .


Expected results:

The attribute seems to exist. It does not occur only in the addon, but also in Mozilla code, see bug 509209. So there should be documentation.

Comment 1

6 years ago
It's just a custom attribute used by the messagecompose window. I'd put it in Thunderbird specific documentation, and not under XUL attributes.
(Reporter)

Comment 2

6 years ago
Is there already documentation where this would fit? IMO, there should be documentation for XUL document of Thunderbird about what has to be observed when creating an overlay for it.

Comment 3

6 years ago
I suggest that you get on IRC and connect to irc://moznet/maildev (this is the maildev channel on the mozdev IRC server). There should be people there who can suggest the proper place to place such documentation.
(Reporter)

Comment 4

6 years ago
<sid0> tessarakt2: see https://mxr.mozilla.org/comm-central/search?find=%2F&string=disableonsend
<sid0> seems like it's a custom attribute used by our compose code
<tessarakt2> yeah
<tessarakt2> is there documentation on what you have to care about when writing a XUL overlay?
<tessarakt2> (i.e., an overlay for a specific window)
<tessarakt2> or should there be such documentation?
<sid0> well, this is custom and highly specific
<sid0> there probably should be documentation for this
<sid0> and this is like a lot of other custom attributes we probably define
<tessarakt2> I guess if you leave it out, something will break
(Assignee)

Updated

5 years ago
Component: Documentation Requests → Documentation
Product: Mozilla Developer Network → Mozilla Developer Network
Component: Documentation → General
Product: Mozilla Developer Network → Developer Documentation
This should actually be documented right in the XUL reference, but flagged as Thunderbird specific.
Component: General → Mozilla Platform
Whiteboard: u=mozdev p=1
Whiteboard: u=mozdev p=1 → u=mozdev p=1 c=Platform
XUL is going away. No Staff Writer will ever work on this.

We will still accept contributed documentation though: reopen only if you start documenting it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 7

2 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #6)
> XUL is going away. No Staff Writer will ever work on this.
> 
> We will still accept contributed documentation though: reopen only if you
> start documenting it.
Nobody is going to contribute to a bug that is marked WONTFIX.
I'm setting this as a GFB so that bugsahoy can pick this up.
http://www.joshmatthews.net/bugsahoy/
Mentor: blog@tessarakt.de, vseerror@lehigh.edu, philip.chee@gmail.com
Status: RESOLVED → REOPENED
Ever confirmed: true
Keywords: helpwanted
Resolution: WONTFIX → ---
Whiteboard: u=mozdev p=1 c=Platform → [good first bug][lang=html]

Comment 8

4 months ago
hi. I would like to contribute to the documentation. Since it is my maiden attempt towards the documentation bugs, I request you to help me getting started.
You need to log in before you can comment on or make changes to this bug.