DebugBreak starting mailnews

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: Akkana Peck, Assigned: Robert John Churchill)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
There's a DebugBreak that happens every time I bring up the mailnews window.
Setting a breakpoint there reveals that nsError is being called, with the string
"couldn't create instance of collation factory".  Here's the stack trace:

#0  nsDebug::Break (
    aFile=0x40b25952 "/builds/mon/mozilla/rdf/content/src/nsXULSortService.cpp",
aLine=281) at /builds/mon/mozilla/xpcom/src/nsDebug.cpp:100
#1  0x4003f1a1 in nsDebug::Error (
    aMessage=0x40b259ca "couldn't create instance of collation factory",
    aFile=0x40b25952 "/builds/mon/mozilla/rdf/content/src/nsXULSortService.cpp",
aLine=281) at /builds/mon/mozilla/xpcom/src/nsDebug.cpp:174
#2  0x40af46fc in ?? ()
#3  0x40af4cc4 in ?? ()
#4  0x40af9b9d in ?? ()
#5  0x40a9eea8 in ?? ()
#6  0x40042016 in nsComponentManagerImpl::CreateInstance (this=0x8050a20,
    aClass=@0x40b2139c, aDelegate=0x0, aIID=@0x40b213ac, aResult=0xbfffe0f0)
    at /builds/mon/mozilla/xpcom/src/nsComponentManager.cpp:1118
#7  0x400444c8 in nsComponentManager::CreateInstance (aClass=@0x40b2139c,
    aDelegate=0x0, aIID=@0x40b213ac, aResult=0xbfffe0f0)
    at /builds/mon/mozilla/xpcom/src/nsRepository.cpp:67
#8  0x40044fb3 in nsServiceManagerImpl::GetService (this=0x8050578,
    aClass=@0x40b2139c, aIID=@0x40b213ac, result=0x40b2a8e0,
    shutdownListener=0x0)
    at /builds/mon/mozilla/xpcom/src/nsServiceManager.cpp:243
#9  0x40045718 in nsServiceManager::GetService (aClass=@0x40b2139c,
    aIID=@0x40b213ac, result=0x40b2a8e0, shutdownListener=0x0)
    at /builds/mon/mozilla/xpcom/src/nsServiceManager.cpp:445
(more stack available upon request)

Updated

19 years ago
Assignee: phil → putterman

Comment 1

19 years ago
Reassign to putterman, cc rjc

Updated

19 years ago
Assignee: putterman → rjc

Comment 2

19 years ago
from the break comment it looks like it's happening in nsXULSortService.  We've
had these kind of problems on Linux before.  Reassigning to rjc, in case he's
not doing something correctly, but the bug is potentially tague's or nhotta's.

I'm not seeing this on my Linux build from when the tree was closed this
morning.  There were some changes yesterday in the intl code that were supposed
to make this work on Linux(it probably wasn't before the checkin).  Have you
pulled that change (intl/locale/src/unix/nsLocaleSO.cpp)?
(Reporter)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

19 years ago
Sure enough, this has gone away in today's build.  Taking the liberty of
closing.

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 4

19 years ago
Since the reporter (Akkana) has said this is fixed, I'll go ahead and mark it
verified. Thanks!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.