Status

Mozilla Developer Network
Wiki pages
P3
normal
RESOLVED DUPLICATE of bug 839214
7 years ago
4 years ago

People

(Reporter: openjck, Unassigned)

Tracking

Details

(Whiteboard: u=contributor c=search p=)

(Reporter)

Description

7 years ago
Search rankings should be based on search terms, article ratings, and anything else that makes the results more relevant.

Perhaps administrators should be able to "bump" articles; that is, if a page is the definitive resource for a topic, the administrator should be able to weight the article so that it appears higher in the search results. For example, if a user searches for "JavaScript", the "Core JavaScript Reference" should appear high in the results because it is the definitive resource.
(Reporter)

Updated

7 years ago
Priority: -- → P4
(Reporter)

Updated

7 years ago
Priority: P4 → P3
(Reporter)

Updated

7 years ago
Blocks: 506266

Updated

6 years ago
Blocks: 756266
No longer blocks: 506266

Updated

6 years ago
No longer blocks: 756266

Updated

6 years ago
Blocks: 756266

Comment 1

6 years ago
Discussed in New York: curated results.

The idea would start with statistics over what people search. It's important to "bump" or curate based on what people search for.

A first heavily-automatisable step is to record which result is clicked for which query string (with removal if the user presses 'back'). That would be an interesting way to crowdsource the search.
Human confirmation might be necessary here.

Other than that, for most searched terms, we (trusted contributors) could curate what we think is relevant for that search. If nothing is, it might be a good indicator of a missing page or tutorial, etc.
(Reporter)

Updated

6 years ago
Summary: Improved search relevancy → Improve site search
(Reporter)

Updated

6 years ago
Depends on: 452947
(Reporter)

Updated

6 years ago
Depends on: 474390
(Reporter)

Updated

6 years ago
Depends on: 506266
(Reporter)

Updated

6 years ago
Depends on: 772692
(Assignee)

Updated

5 years ago
Version: Kuma → unspecified
(Assignee)

Updated

5 years ago
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
(Reporter)

Updated

5 years ago
No longer blocks: 756266

Updated

5 years ago
Depends on: 860024
(Reporter)

Comment 2

5 years ago
We are working on this with bug 839214. Let's move discussion there.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 839214
You need to log in before you can comment on or make changes to this bug.