Please Update Website Content: http://www.mozilla.org/projects/firefox/

RESOLVED FIXED

Status

RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: gjimenez, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Hi Laura, 

Not sure who is the owner of this page, but the content is outdated.
Apparently, the beta in-product billboards links to this page, so it would be great if we can make sure the content is updated.

Currently the page looks like this:     
Latest build: Minefield (nightly build)
Next release: Firefox 5
Current release: Firefox 4
Previous supported release: Firefox 3.6

Since we dropped the numbers, here is my proposal:
Upcoming Builds: 
Nightly
Aurora
Beta  
Current release: (link to current release)
Previous supported release: Firefox 3.6 (do you think we still need this?)
We should also add:
Firefox in Mobile: 
Firefox Mobile Beta for Android
Firefox for Mobile 


Again, I was informed that the current billboard to update beta 5 to 6 is linking to this page, so if we can fix it as soon as possible that would be great!

thanks!

Comment 1

7 years ago
I'll take this.  The page doesn't really have an owner right now, but I can update things as needed.  Will post in a few minutes when the changes go live.

Updated

7 years ago
Duplicate of this bug: 655120

Comment 3

7 years ago
The page has been updated with current information.  Closing as fixed, but feel free to reopen if there are more tweaks to make.

For background, a discussion of the purpose and need for this page is in bug 350989.  Feel free to comment there if you have thoughts or suggestions about this page beyond short term updates to make the content current.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.