Intermittent timeout in /tests/content/media/test/test_buffered.html | Exited with code -1073741819 during test run

RESOLVED WORKSFORME

Status

()

defect
RESOLVED WORKSFORME
8 years ago
7 years ago

People

(Reporter: cpearce, Unassigned)

Tracking

({intermittent-failure})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Test timeout on Win7 mochitest 1/5, just 1 changeset after landing the dethreadification in bug 592833.

I'm not convinced it's caused by the landing of bug 592833, but filing in video to track until we have more info.

s: talos-r3-w7-049
TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_buffered.html | Exited with code -1073741819 during test run
Bug 591790 - Intermittent test_buffered.html | Test timed out. followed by shutdown hang with nsBuiltinDecoder on the stack PROCESS-CRASH | /tests/content/media/test/test_buffered.html | application crashed (minidump found)
Thread 3 (crashed)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!
TEST-UNEXPECTED-FAIL | plugin process 2904 | automationutils.processLeakLog() | missing output line for total leaks!

Mochitest log:
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1310458614.1310461349.14485.gz&fulltext=1#err2


67079 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: Should be buffered in one range - 1 should equal 1
67080 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: First range start should be media start - 0 should equal 0
67081 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: First range end should be media end - 0.266664 should equal 0.266664
67082 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: Should throw INDEX_SIZE_ERR on under start bounds range - true should equal true
67083 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: Should throw INDEX_SIZE_ERR on under end bounds range - true should equal true
67084 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: Should throw INDEX_SIZE_ERR on over start bounds range - true should equal true
67085 INFO TEST-PASS | /tests/content/media/test/test_buffered.html | 320x240.ogv: Should throw INDEX_SIZE_ERR on over end bounds range - true should equal true
before 978944, after 978944, break 00000000
WARNING: shutting down early because of crash!: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/plugins/ipc/PluginModuleChild.cpp, line 696
WARNING: plugin process _exit()ing: file e:/builds/moz2_slave/m-in-w32-dbg/build/dom/plugins/ipc/PluginModuleChild.cpp, line 688



Crashing thread, doesn't look like a media thread:

Thread 3 (crashed)
 0  xul.dll!mozilla::BlockingResourceBase::CheckAcquire(mozilla::CallStack const &) [BlockingResourceBase.cpp:d734e168a228 : 130 + 0x6]
    eip = 0x6a0a3829   esp = 0x02e4f8c4   ebp = 0x02e4f93c   ebx = 0x005b5b38
    esi = 0x00000000   edi = 0x00000000   eax = 0x1524bcf8   ecx = 0xdddddddd
    edx = 0x00000000   efl = 0x00010286
    Found by: given as instruction pointer in context
 1  xul.dll!mozilla::Mutex::Lock() [BlockingResourceBase.cpp:d734e168a228 : 260 + 0xb]
    eip = 0x6a0a3dd3   esp = 0x02e4f944   ebp = 0x02e4f950
    Found by: call frame info
 2  xul.dll!mozilla::MutexAutoLock::MutexAutoLock(mozilla::Mutex &,mozilla::GuardObjectNotifier const &) [Mutex.h:d734e168a228 : 184 + 0x9]
    eip = 0x68d434c1   esp = 0x02e4f958   ebp = 0x02e4f95c
    Found by: call frame info
 3  xul.dll!nsThread::GetObserver(nsIThreadObserver * *) [nsThread.cpp:d734e168a228 : 689 + 0x17]
    eip = 0x6a1021ee   esp = 0x02e4f964   ebp = 0x02e4f97c
    Found by: call frame info
 4  xul.dll!nsThread::GetObserver() [nsThread.h:d734e168a228 : 90 + 0xc]
    eip = 0x6a1016d6   esp = 0x02e4f984   ebp = 0x02e4f994
    Found by: call frame info
 5  xul.dll!nsThread::PutEvent(nsIRunnable *) [nsThread.cpp:d734e168a228 : 381 + 0xb]
    eip = 0x6a10166e   esp = 0x02e4f99c   ebp = 0x02e4f9c8
    Found by: call frame info
 6  xul.dll!nsThread::Dispatch(nsIRunnable *,unsigned int) [nsThread.cpp:d734e168a228 : 421 + 0xb]
    eip = 0x6a10189e   esp = 0x02e4f9d0   ebp = 0x02e4f9f4
    Found by: call frame info
 7  xul.dll!nsTimerImpl::PostTimerEvent() [nsTimerImpl.cpp:d734e168a228 : 557 + 0x26]
    eip = 0x6a108870   esp = 0x02e4f9fc   ebp = 0x02e4fa44
    Found by: call frame info
 8  xul.dll!TimerThread::Run() [TimerThread.cpp:d734e168a228 : 300 + 0x7]
    eip = 0x6a109844   esp = 0x02e4fa4c   ebp = 0x02e4fac0
    Found by: call frame info
 9  xul.dll!nsThread::ProcessNextEvent(int,int *) [nsThread.cpp:d734e168a228 : 617 + 0x18]
    eip = 0x6a101f84   esp = 0x02e4fac8   ebp = 0x02e4fb28
    Found by: call frame info
10  xul.dll!NS_ProcessNextEvent_P(nsIThread *,int) [nsThreadUtils.cpp:d734e168a228 : 245 + 0x15]
    eip = 0x6a0a25b3   esp = 0x02e4fb30   ebp = 0x02e4fb44
    Found by: call frame info
11  xul.dll!nsThread::ThreadFunc(void *) [nsThread.cpp:d734e168a228 : 272 + 0xa]
    eip = 0x6a100ebe   esp = 0x02e4fb4c   ebp = 0x02e4fb7c
    Found by: call frame info
12  nspr4.dll!_PR_NativeRunThread [pruthr.c:d734e168a228 : 426 + 0xe]
    eip = 0x73dfc8bb   esp = 0x02e4fb84   ebp = 0x02e4fb8c
    Found by: call frame info
13  nspr4.dll!pr_root [w95thred.c:d734e168a228 : 122 + 0xe]
    eip = 0x73e00f49   esp = 0x02e4fb94   ebp = 0x02e4fb9c
    Found by: call frame info
14  msvcr80d.dll + 0x48d0
Blocks: 438871
(In reply to comment #7)
> mak77%bonardo.net
> http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1311852309.
> 1311854688.27653.gz
> Rev3 WINNT 6.1 mozilla-inbound debug test mochitests-1/5 on 2011/07/28
> 04:25:09
> 
> s: talos-r3-w7-017
> TEST-UNEXPECTED-FAIL | /tests/content/media/test/test_buffered.html | Exited
> with code -1073741819 during test run
> PROCESS-CRASH | /tests/content/media/test/test_buffered.html | application
> crashed (minidump found)
> Thread 3 (crashed)
> TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output
> line for total leaks!
> TEST-UNEXPECTED-FAIL | plugin process 356 | automationutils.processLeakLog()
> | missing output line for total leaks!

This log contains the following errors:

WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x8007000E: file e:/builds/moz2_slave/m-in-w32-dbg/build/obj-firefox/xpcom/build/nsThreadUtils.cpp, line 83
###!!! ABORT: Can't create media state machine thread: 'NS_SUCCEEDED(res)', file e:/builds/moz2_slave/m-in-w32-dbg/build/content/media/nsBuiltinDecoderStateMachine.cpp, line 232

This failure is caused by us failing to allocate a thread for the media player. Note this happened after I landed bug 664341, which reduces the amount of memory reserved for thread stacks for the media threads.

These failures may be hidden in opt builds/runs because we don't log NS_ENSURE_SUCCESS or NS_WARNINGs in opt builds.

The other debug logs don't contain this warning, so either malloc/new is failing somewhere else, or there's at least one other way this test can fail.
Whiteboard: [orange]
Resolving WFM any keyword:intermittent-failure bug where:
* Changed: (is less than or equal to) -3m
* Whiteboard: (contains none of the strings) random disabled marked fuzzy todo fails failing annotated time-bomb
* Whiteboard: (does not contain the string) leave open

There will inevitably be some false positives; for that (and the bugspam) I apologise, but at least this will clear out the open cruft (and thus reduce risk of mis-starring) on TBPL's annotated summary bug suggestions.

Filter on orangewfm.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.