Last Comment Bug 670913 - LayerManagerD3D10.h fails to compile on mingw
: LayerManagerD3D10.h fails to compile on mingw
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: mozilla8
Assigned To: Jacek Caban
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-12 06:27 PDT by Jacek Caban
Modified: 2011-07-13 15:27 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix v1.0 (857 bytes, patch)
2011-07-12 06:27 PDT, Jacek Caban
joe: review+
Details | Diff | Review

Description Jacek Caban 2011-07-12 06:27:08 PDT
Created attachment 545369 [details] [diff] [review]
fix v1.0

That's because of wrong syntax:

static void LayerManagerD3D10::ReportFailure(const nsACString &aMsg, HRESULT aCode);

inside LayerManagerD3D10 class. 'LayerManagerD3D10::' should not be there.
Comment 1 Jacek Caban 2011-07-13 09:09:28 PDT
Thanks for the review, pushed to m-i:

http://hg.mozilla.org/integration/mozilla-inbound/rev/ebdc61782fba
Comment 2 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-13 15:27:46 PDT
http://hg.mozilla.org/mozilla-central/rev/ebdc61782fba

Note You need to log in before you can comment on or make changes to this bug.