Last Comment Bug 670939 - Draft's are saved in drafts subfolder but not synchronised with Gmail drafts folder
: Draft's are saved in drafts subfolder but not synchronised with Gmail drafts ...
Status: RESOLVED FIXED
:
Product: MailNews Core
Classification: Components
Component: Networking: IMAP (show other bugs)
: Trunk
: All Other
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks: tb-gmailWIP
  Show dependency treegraph
 
Reported: 2011-07-12 08:39 PDT by Tom Snyman
Modified: 2012-11-17 17:01 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Tom Snyman 2011-07-12 08:39:00 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Saved message as draft


Actual results:

message saved in drafts subfolder but not synchronized with Gmail drafts folder


Expected results:

Saved in drafts folder and syncronized with Gmail drafts folder
Comment 1 Tom Snyman 2011-07-18 05:17:39 PDT
Re-tried today after loading Shredder update - same issue the mails in the drafts folder do not synchronisw with the Gmail drafts folder as in previous versions of Thunderbird
Comment 2 Tom Snyman 2011-07-18 05:22:52 PDT
Copies and folders settings for drafts is 'keep messages in draft folder on tomanyman@gmail.com. Note templates are saved correctly in my gmail account!
Comment 3 David :Bienvenu 2011-07-18 08:48:06 PDT
I suspect you have two drafts folders on gmail, perhaps because you used an older version of Thunderbird with gmail at some point. If so, you could try using account settings and pick "Other" and then pick the Gmail/Drafts folder from your gmail account as the drafts folder. If that fixes the issue, then you could move any existing drafts from the old drafts folder (which should no longer have a special icon) and then delete the old drafts folder.
Comment 4 Tom Snyman 2011-07-19 01:18:28 PDT
There is only one drafts folder in Thunderbird properties location is imap://tomsnyman%40gmail.com@imap.googlemail.com/Drafts
Comment 5 Tom Snyman 2011-07-19 01:19:47 PDT
The previous version of Thunderbird handled this syncronisation with no problem?
Comment 6 David :Bienvenu 2011-07-19 06:09:42 PDT
Are you not subscribed to the [GMail]/Drafts folder? If you bring up the subscribe UI (file, subscribe), is there a Drafts sub-folder of the [Gmail] parent folder?
Comment 7 Tom Snyman 2011-07-20 01:12:01 PDT
GMail drafts folder location imap://tomsnyman%40gmail.com@imap.googlemail.com/%5BGmail%5D/Drafts
Does this constitute subscribed?
Comment 8 David :Bienvenu 2011-07-20 07:22:29 PDT
That's the correct gmail drafts folder. I'm a bit confused since you said there's only one drafts folder, but you've cited two different urls as being the draft folder.
Comment 9 Tom Snyman 2011-07-20 08:32:18 PDT
To re-cap Thinderbird draft folders are:
In tomsnyman@gmeil.com folder the location of the Drafts folder is imap://tomsnyman%40gmail.com@imap.googlemail.com/Drafts

In the Gmail folder the location of the Drafts folder is imap://tomsnyman%40gmail.com@imap.googlemail.com/%5BGmail%5D/Drafts

Not sure what the %5BGmail%5D component of the Gmail Drafts location means
Comment 10 Tom Snyman 2011-07-20 08:33:41 PDT
Is there something I can check from a Thunderbird settings perspective or must I do something in Gmail?
Comment 11 David :Bienvenu 2011-07-20 08:39:48 PDT
You want to tell Thunderbird to use the Drafts folder under the [GMail] parent folder, i.e., this one - In the Gmail folder the location of the Drafts folder is imap://tomsnyman%40gmail.com@imap.googlemail.com/%5BGmail%5D/Drafts

See https://bugzilla.mozilla.org/show_bug.cgi?id=670939#c3 for how to tell Thunderbird which Drafts folder to use.
Comment 12 Tom Snyman 2011-07-20 08:54:29 PDT
Okay done that now working fine
Thanks for your patience and help
Comment 13 David :Bienvenu 2011-07-20 11:46:27 PDT
Glad it's working now. I'm not sure why it stopped working for you. Did you upgrade from 3.1? What was the oldest version of TB that you used with this gmail account?
Comment 14 Tom Snyman 2011-07-21 00:56:25 PDT
The previous version that was working fine was Thunderbird Setup 3.1.7 which ws uploaded on 5 Feb 2011
Comment 15 Tom Snyman 2011-07-21 01:01:51 PDT
How do I go about reccomending an enhancement?
Beiung visually impaited I struggle to see the settings pick options as the text is black within a blue background. This means I can not see the text within a highlighted pick option.  Would like to reccomend the text colour is inversed to white when selecting a pick option
Comment 16 David :Bienvenu 2011-07-21 07:28:29 PDT
(In reply to comment #15)
> How do I go about reccomending an enhancement?
> Beiung visually impaited I struggle to see the settings pick options as the
> text is black within a blue background. This means I can not see the text
> within a highlighted pick option.  Would like to reccomend the text colour
> is inversed to white when selecting a pick option

You could file a new bug on that. A screen shot would probably be helpful as well but if I understand you correctly, that's true for everything we select. You might try a different theme from addons.mozilla.org
Comment 17 Tom Snyman 2011-07-21 08:54:37 PDT
Okay will try this
Comment 18 Tom Snyman 2011-07-23 02:29:49 PDT
The default theme is 8.0a1 last updated 12 July 2011
There are no alternative themes to add-on

Note You need to log in before you can comment on or make changes to this bug.