Closed Bug 670940 Opened 8 years ago Closed 8 years ago

Include current iteration and micro-iteration in endurance checkpoints

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: davehunt, Assigned: davehunt)

References

Details

(Whiteboard: [mozmill-endurance])

Attachments

(1 file, 2 obsolete files)

As mentioned on bug 669869 and bug 669870, it would be useful to see the current iteration and micro-iteration in the endurance tests dashboard. A suggested way to do this would be to include these numbers in each checkpoint.
Assignee: nobody → dave.hunt
Blocks: 629065
Whiteboard: [mozmill-endurance]
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/15824761
Added a loop method for micro-iterations, and report current iteration/micro-iteration in the checkpoint labels. Also updated the two tests that use micro-iterations to use the new method.
Attachment #546480 - Flags: review?(hskupin)
Comment on attachment 546480 [details] [diff] [review]
Include current iteration and micro-iteration in endurance checkpoints. v1.0

>+      this._currentIteration = i+1;

This needs spaces around the operator.

>+  loop : function endurance_loop(callback) {

This needs a better name which has to be connected to micro iterations.

>+      this._currentMicroIteration = i+1;

Same as above.
Attachment #546480 - Flags: review?(hskupin) → review-
(In reply to comment #3)
> Comment on attachment 546480 [details] [diff] [review] [review]
> Include current iteration and micro-iteration in endurance checkpoints. v1.0
> 
> >+      this._currentIteration = i+1;
> 
> This needs spaces around the operator.

Done.

> >+  loop : function endurance_loop(callback) {
> 
> This needs a better name which has to be connected to micro iterations.

I don't agree that the name has to reflect micro-iterations, in fact I think this would make it more confusing. Unless you have a better suggestion for a name then I think loop is the simplest to understand.

> >+      this._currentMicroIteration = i+1;
> 
> Same as above.

Done.
Attachment #546480 - Attachment is obsolete: true
Attachment #546547 - Flags: review?(hskupin)
Comment on attachment 546547 [details] [diff] [review]
Include current iteration and micro-iteration in endurance checkpoints. v1.1

So lets take loop for now. I don't have a proposal for another name right now.
Attachment #546547 - Flags: review?(hskupin) → review+
Updated patch because it was based on another patch that hasn't landed yet.
Attachment #546547 - Attachment is obsolete: true
Attachment #546807 - Flags: review?(hskupin)
Attachment #546807 - Flags: review?(hskupin) → review+
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.