Closed Bug 671106 Opened 8 years ago Closed 8 years ago

Intermittent leak in mochitest-plain-3, including 13 AsyncStatements and a AsyncStatementParams, BackstagePass, CalculateFrecencyFunction, & Connection

Categories

(Core :: General, defect)

All
Windows 7
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 593711

People

(Reporter: dholbert, Unassigned)

References

()

Details

(Keywords: intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Inbound/1310505722.1310508257.28018.gz
Rev3 WINNT 6.1 mozilla-inbound debug test mochitests-3/5 on 2011/07/12 14:22:02

s: talos-r3-w7-046
{
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 23384 bytes during test execution
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 13 instances of AsyncStatement with size 48 bytes each (624 bytes total)
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of AsyncStatementParams with size 20 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of BackstagePass with size 24 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of CalculateFrecencyFunction with size 12 bytes
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | leaked 1 instance of Connection with size 112 bytes
}

"Analyze the leak" link says "No DOMWINDOWs leaked!"
I think this is a duplicate of bug 593711.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 593711
I'm not so sure -- in that bug, a MatchAutoCompleteFunction is leaked, whereas here a CalculateFrecencyFunction is leaked.

Is that unimportant?
(previous comment applies to the leak in bug 593711 comment 0.  I see that the log most recently posted there had a CalculateFrecencyFunction leaked, so maybe it's broadened since it was filed.)
All of the more recent builds starred as bug 593711 leak a CalculateFrecencyFunction.  It looks like the exact contents of that leak have changed since bug 593711 comment 0.
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.