Javascript generated frames <A> href target + onClick event problem

RESOLVED DUPLICATE of bug 64202

Status

()

RESOLVED DUPLICATE of bug 64202
18 years ago
16 years ago

People

(Reporter: iserlohn, Assigned: joki)

Tracking

({dom0})

Trunk
Future
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Bug appears on Win32 Builds
Bug does not appear on Linux builds.
Bug appears in 0.7 and all subsequent nightlies.

See URL for details. A Javascript program in a parent that generates the 
display code in a frame works well in Mozilla 0.7 on Linux. However on Win32, 
the <A href="xxx" target="xxx" onClick="xxx"> tags only calls the onClick 
event, but does not activate the link in the desired frame. If we remove 
the "onClick" event, then the frame does load correctly.

Comment 1

18 years ago
updating component.
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale
Reassigning to joki.
Assignee: jst → joki

Comment 3

18 years ago
WORKSFORME
Platform: PC
OS: Windows 98
Mozilla Build: 2001012904

Reporter try downloading the latest nightly at
http://www.mozillazine.org/build_comments/ and create a new profile. See if that
fixes the problem. Report back either way.
(Reporter)

Comment 4

18 years ago
OS: Windows 2000
Build: 2001020104 , 2001013104

The newest builds still exhibits the problem.

Comment 5

18 years ago
Marking NEW as per comments.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: dom0
(Reporter)

Comment 6

18 years ago
Tested this out recently. Windows Build 2001030804 still has the problem.

Comment 7

18 years ago
joki is pretty swamped.  Futuring unless this can be argued to be very serious.
Target Milestone: --- → Future

Comment 8

18 years ago
Is this fixed now? The menu seems to work well in M0.91/win98.
If it's fixed, this is probably due to the patch attached by rpotts to bug 65777.

Comment 9

17 years ago
Looks like bug 64202, or related. Thoughts?

Comment 10

16 years ago
re comment 8
no response from reporter (Andy Kwong), url not working, no testcase
-> dupe

*** This bug has been marked as a duplicate of 64202 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
Summary: [Win32]Javascript generated frames <A> href target + onClick event problem → Javascript generated frames <A> href target + onClick event problem
You need to log in before you can comment on or make changes to this bug.