Last Comment Bug 671150 - Add memory reporter for the JS PropertyTable
: Add memory reporter for the JS PropertyTable
Status: RESOLVED FIXED
[MemShrink:P2][inbound]
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla8
Assigned To: Nicholas Nethercote [:njn]
:
: Jason Orendorff [:jorendorff]
Mentors:
Depends on:
Blocks: DarkMatter
  Show dependency treegraph
 
Reported: 2011-07-12 18:04 PDT by Nicholas Nethercote [:njn]
Modified: 2011-07-25 06:16 PDT (History)
8 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (9.10 KB, patch)
2011-07-21 00:09 PDT, Nicholas Nethercote [:njn]
brendan: review+
Details | Diff | Splinter Review

Description Nicholas Nethercote [:njn] 2011-07-12 18:04:13 PDT
Bug 563700 says that js::PropertyTable::init() and js::PropertyTable::change() together account for 4.3% in one profile of gmail.
Comment 1 Nicholas Nethercote [:njn] 2011-07-21 00:09:34 PDT
Created attachment 547331 [details] [diff] [review]
patch

Fairly straightforward.
Comment 2 Nicholas Nethercote [:njn] 2011-07-21 00:16:03 PDT
I'm seeing this reduce heap-unclassified by about 2% on normal (for me) browsing.  Not as much as I'd hoped, but better than a kick in the teeth.
Comment 3 [PTO to Dec5] Bill McCloskey (:billm) 2011-07-21 09:15:15 PDT
Maybe this should go in a different bug, but it would be nice also to count the size of the hashtable holding each shape's children.
Comment 4 Nicholas Nethercote [:njn] 2011-07-21 16:57:29 PDT
(In reply to comment #3)
> Maybe this should go in a different bug, but it would be nice also to count
> the size of the hashtable holding each shape's children.

Just to clarify (for my own benefit):  Shape::kids can point to a KidsHash (which is a typedef for a HashSet, and that's not accounted for.
Comment 5 Brendan Eich [:brendan] 2011-07-22 14:37:17 PDT
Comment on attachment 547331 [details] [diff] [review]
patch

entriesSize vs. sizeOf name nit: how about sizeOfEntries instead of entriesSize? More self-consistent, prettier because it avoids the sS conjunction.

r=me with that.

/be
Comment 6 Nicholas Nethercote [:njn] 2011-07-24 17:05:14 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/2d63d7fd35a0
Comment 7 Marco Bonardo [::mak] 2011-07-25 06:16:53 PDT
http://hg.mozilla.org/mozilla-central/rev/2d63d7fd35a0

Note You need to log in before you can comment on or make changes to this bug.