Last Comment Bug 671160 - ASSERTION: Uh, inner window set as event target!
: ASSERTION: Uh, inner window set as event target!
Status: VERIFIED FIXED
[sg:high][qa-]
: assertion, regression
Product: Toolkit
Classification: Components
Component: Password Manager (show other bugs)
: Trunk
: x86_64 Linux
: P1 normal (vote)
: mozilla8
Assigned To: Boris Zbarsky [:bz] (still a bit busy)
:
: Matthew N. [:MattN] (PM me if requests are blocking you)
Mentors:
: 671392 671688 (view as bug list)
Depends on:
Blocks: 648045
  Show dependency treegraph
 
Reported: 2011-07-12 18:48 PDT by Mats Palmgren (:mats)
Modified: 2012-01-19 11:32 PST (History)
8 users (show)
bzbarsky: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
unaffected
unaffected
unaffected
+
fixed
+
fixed
+
fixed
unaffected
unaffected


Attachments
stack at the assertion (25.39 KB, text/plain)
2011-07-13 04:24 PDT, Mats Palmgren (:mats)
no flags Details
Fix (1.11 KB, patch)
2011-07-13 10:21 PDT, Boris Zbarsky [:bz] (still a bit busy)
bugs: review+
Details | Diff | Splinter Review

Description Mats Palmgren (:mats) 2011-07-12 18:48:09 PDT
STEPS TO REPRODUCE
1. run mochitest toolkit/components/passwordmgr/test/test_master_password.html

ACTUAL RESULTS
###!!! ASSERTION: Uh, inner window set as event target!: '!win || !win->IsInnerWindow()', file content/events/src/nsDOMEvent.cpp, line 878

PLATFORMS AND BUILDS TESTED
Bug occurs in a local mozilla-central DEBUG build on Linux x86-64
Comment 1 Olli Pettay [:smaug] 2011-07-13 03:19:09 PDT
Can't reproduce. Can you get the stack?
Comment 2 Mats Palmgren (:mats) 2011-07-13 04:24:19 PDT
Created attachment 545641 [details]
stack at the assertion
Comment 3 Olli Pettay [:smaug] 2011-07-13 10:05:29 PDT
Bz, probably a regression from nsGlobalWindow::DispatchCustomEvent change.
We should dispatch the event to outer window.

Sorry, I should have noticed the problem when reviewing.

We could either just fix this bug, or make
event dispatching to handle this case.
I think I prefer the first option, since that forces caller to think about
whether to use inner or outer window.
Comment 4 Boris Zbarsky [:bz] (still a bit busy) 2011-07-13 10:21:17 PDT
Created attachment 545692 [details] [diff] [review]
Fix
Comment 5 Boris Zbarsky [:bz] (still a bit busy) 2011-07-13 19:04:10 PDT
Daniel, please don't nuke my status whiteboard annotations?  I actually use them to track what I need to do...
Comment 6 Boris Zbarsky [:bz] (still a bit busy) 2011-07-13 19:54:36 PDT
*** Bug 671392 has been marked as a duplicate of this bug. ***
Comment 7 Daniel Holbert [:dholbert] 2011-07-14 16:26:32 PDT
*** Bug 671688 has been marked as a duplicate of this bug. ***
Comment 8 Boris Zbarsky [:bz] (still a bit busy) 2011-07-14 19:18:34 PDT
http://hg.mozilla.org/integration/mozilla-inbound/rev/553625d7875d
Comment 10 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-07 13:17:19 PST
Is there something QA can do to verify this fix? If not, could you verify the fix Mats?
Comment 11 Mats Palmgren (:mats) 2011-12-07 14:11:52 PST
The test pass with no assertions in my local debug build on Linux64.
Backing out the fix brings it back.
Comment 12 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-07 14:35:45 PST
Thanks Mats.

Note You need to log in before you can comment on or make changes to this bug.