mousing over ``kelly wiglesworth'' causes link to duplicate

VERIFIED FIXED

Status

()

VERIFIED FIXED
18 years ago
18 years ago

People

(Reporter: waterson, Assigned: waterson)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Assignee)

Description

18 years ago
To reproduce,

1. Go to above link
2. Mouse over ``kelly wiglesworth''
3. Note that text repeats on each mouse enter/exit
(Assignee)

Comment 1

18 years ago
Created attachment 23916 [details]
reduced test case
(Assignee)

Comment 2

18 years ago
Spent some time reducing: looks to have something to do with the fact that there
are two floaters, and no whitespace between the first floater and the anchor.

Comment 3

18 years ago
duplicate of bug 67118
(Assignee)

Comment 4

18 years ago
*** Bug 67118 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
bug 67112 looks the same
OS: Windows 2000 → All
Hardware: PC → All

Comment 6

18 years ago
*** Bug 67112 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

18 years ago
The problem is this. There are two floaters in the <body>'s block frame's 
floater list. The new GetPrimaryFrameFor() hint mechanism is passing the first 
floater (an image) as the hint. This sends 
nsCSSFrameConstruct::FindFrameWithContent() off into the weeds: the hint frame 
is in the floated list, not the primary frame list, so we never properly search 
the primary frame list. Attaching a patch to fix this.
(Assignee)

Comment 8

18 years ago
Created attachment 23950 [details] [diff] [review]
re-search primary frame list if we've got a hint that didn't work the first time through
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Keywords: regression

Comment 9

18 years ago
Patch looks fine to me, nice and simple. r=attinasi@netscape.com

Comment 10

18 years ago
looks good to me. sr=buster.  it makes searching longer for content that doesn't
have a frame (displayType = none), but that issue is covered in another bug
already.  in a better world, we should never even get into this code unless the
content has a frame.
(Assignee)

Comment 11

18 years ago
fix checked in
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
VERIFIED FIXED on build 2001020504 (windows 2000), build 2001020513 (mac os
9.0.4) and build 2001020506 (linux redhat 7.0).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.