Last Comment Bug 671256 - [RFE] Set some passwords in the login manager before browser window loads.
: [RFE] Set some passwords in the login manager before browser window loads.
Status: RESOLVED DUPLICATE of bug 568943
:
Product: Testing
Classification: Components
Component: Mozbase (show other bugs)
: unspecified
: All All
: -- enhancement with 1 vote (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-13 06:41 PDT by Marc-Aurèle DARCHE
Modified: 2011-07-13 06:58 PDT (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Marc-Aurèle DARCHE 2011-07-13 06:41:05 PDT
Usecase:

Some extensions (this is at least is the case of the Fidesfit-client extension) may want to check the presence of a user password (stored in the login manager) at startup (when the browser window loads) and open a mandatory configuration window the user has to fill in.

If this password is programmatically set in the setupModule function, it's already too late, the extension is already loaded and the configuration window will be opened at the beginning of each Mozmill test, which will be very tedious, impractical.

Possible solutions:

One solution is to use the Mozmill "--profile" option with a profile directory containing a specially filled signons.sqlite file, along with its key3.db file, that only contains the needed dummy login+password for the specific tests. This works.

But it isn't really resilient, since it's based on how this information is stored. And so far I've only tested this on Linux (maybe logins + passwords are stored differently for example on Windows leveraging possible builtin secure store there).

So a practical Mozmill enhancement would be to be able to specify a password file (containing login and password pairs), either in JSON or .ini format, as an option to Mozmill.

Thank you
Comment 1 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2011-07-13 06:52:54 PDT
That has already been filed as bug 568943 a while back.
Comment 2 Marc-Aurèle DARCHE 2011-07-13 06:55:42 PDT
(In reply to comment #1)
> That has already been filed as bug 568943 a while back.

Yes kind of. But this new ticket is really more focused and with a usecase.
Comment 3 Henrik Skupin (:whimboo) [away 09/30 - 10/06] 2011-07-13 06:58:35 PDT
The use case is clear since the beginning of bug 568943. I made a comment over there. So please let us focus on the initial bug request.

*** This bug has been marked as a duplicate of bug 568943 ***

Note You need to log in before you can comment on or make changes to this bug.