Click on Facebook Login button throws exception

RESOLVED DUPLICATE of bug 648250

Status

Firefox for Android Graveyard
General
P2
normal
RESOLVED DUPLICATE of bug 648250
7 years ago
4 years ago

People

(Reporter: tarend, Assigned: mfinkle)

Tracking

Trunk
ARM
Android

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Lloyd S. reports this bug, which I can reproduce on the desktop build and on a Galaxy Tab and Galaxy S:

(1) Go to http://www.ottawabluesfest.ca/performances/mycalendar
(2) Click on the "Login using Facebook" button (top right, under "Tickets")

Expected: Login dialog appears
Result: nothing, error console shows this exception:

uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMWindowInternal.screenX]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: http://connect.facebook.net/en_US/all.js :: <TOP_LEVEL> :: line 22"  data: no]
(Reporter)

Comment 1

7 years ago
Ah, seems like the Facebook login button tries to open to login dialog in a new window, tab, or popup - that is what happens on desktop, btw.
Created attachment 545673 [details] [diff] [review]
patch

nsGlobalWindow::GetScreenX will eventually make it's way to TabChild::GetDimensions, which is currently not implemented.

This patch implements TabChild::GetDimensions using the same technique I see in nsSiteWindow2 here:
http://mxr.mozilla.org/mozilla-central/source/xpfe/appshell/src/nsContentTreeOwner.cpp#1053

With this patch the "Login with Facebook" feature works. It just wants to open a new window. In Fennec, we open it as a new tab.

I kept tab spacing at 2 spaces, which is what the surrounding code uses, but the file uses a mixture of 2 and 4 spaces. Let me know if I should switch to 4 spaces.

Chris - If you're not the right guy I can try Smaug
Assignee: nobody → mark.finkle
Attachment #545673 - Flags: review?(jones.chris.g)
Duplicate of bug 648250?
(In reply to comment #3)
> Duplicate of bug 648250?

Sure seems like it. The patch in bug 648250 uses remoting, where mine is a bit more simple minded (and could be plain wrong).
Comment on attachment 545673 [details] [diff] [review]
patch

Better patch direction in bug 648250
Attachment #545673 - Flags: review?(jones.chris.g)
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648250
You need to log in before you can comment on or make changes to this bug.