If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Internet keyword search doesn't work for only one word under Linux

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: Yongzhi Pan, Unassigned)

Tracking

5 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110622232440

Steps to reproduce:

Type 'abc' and enter in the location bar.


Actual results:

Firefox tried to resolve it as a domain name, and I am redirected to my ISP's ad page for invalid domain.


Expected results:

I should see Google search result for 'abc'. However, this works for more than one words, e.g. 'abc abc'. This is under Ubuntu. However, it works fine under Windows for one or more than one words.
(Reporter)

Updated

6 years ago
OS: Other → Linux

Comment 1

6 years ago
Works for me:
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110712 Firefox/8.0a1

Does the issue still occur if you start Firefox in Safe Mode?
https://support.mozilla.com/en-US/kb/Safe+Mode

Hm, I guess this may be a DNS issue. 

What output do you get if you enter the commands "nslookup abc" or "dig abc"?

I you temporarily use for example Google as DNS, ip 8.8.8.8, does that make any change?
(Reporter)

Comment 2

6 years ago
I test in safe-mode.

Before changing DNS, 'dig abc' returns the ISP's IP for the ad page domain. I changed DNS to Google (8.8.8.8 and 8.8.4.4), 'dig abc' returns NXDOMAIN error. Firefox directs me to Google search results. I have to test with another word, seems 'abc' DNS lookup result is cached somewhere.

But for a Windows virtual machine on another Ubuntu machine at my home, even I am using the IPS's DNS server, 'nslookup abc' returns IP for the ad page, Firefox still returns Google search results for 'abc'. Though the whole things is not a Firefox bug, I am still puzzled at this.
(Reporter)

Comment 3

6 years ago
Thank you, Thomas. Have Google search in the URL bar is much better!

Comment 4

6 years ago
For single label names like "abc" Windows maybe uses NBNS (NetBios Name Service) instead of the DNS, but nslookup always works against the DNS system.

I'm not sure, but maybe you can see the difference if you use the windows ping command, like "ping abc" (untested).
(Reporter)

Comment 5

6 years ago
For an arbitrary host name 'ping abc' can not find the host. You are probably right. After NBNS lookup fails, firefox resort to Google search. Thank you.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.