created 2 addons with builder. both add an item to context-menu. clicking either one does same action though.

RESOLVED FIXED in 1.1

Status

Add-on SDK
General
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: noitidart, Assigned: adw)

Tracking

unspecified
All
Other

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fixed by bug 669475)

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

created 2 addons with builder. first addon i finished then downloaded then installed. 2nd addon is in testing using the usual builder test button. both addons add an item to context-menu.
1st addon is here: https://builder.addons.mozilla.org/addon/1009452/latest/
2nd addon is here: https://builder.addons.mozilla.org/addon/1009591/latest/


Actual results:

clicking on either item launches the postMessage of the 2nd addon. there was a link in the tab i was in that opened a new window, i right clicked and tested, and now both menu items are launching the postMessage of the 1st addon.


Expected results:

menu item added by installed addon should launch its own postMessage. menu item added by the addon in testing should launch its own postMessage.
(Reporter)

Comment 1

7 years ago
downloaded and installed both addons. same problem.
(Assignee)

Comment 2

7 years ago
Created attachment 545724 [details] [diff] [review]
patch

Thank you very much for reporting this.

The problem is that item IDs are not unique to module instances, but the click-handling code assumes they are.
Assignee: nobody → adw
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #545724 - Flags: review?(myk)
(Reporter)

Comment 3

7 years ago
My pleasure :) So glad I could help. :)
Comment on attachment 545724 [details] [diff] [review]
patch

r=myk
Attachment #545724 - Flags: review?(myk) → review+
(Assignee)

Comment 5

7 years ago
The patch for bug 669475 included the fix to this bug, so marking this bug as fixed.

Thanks again, noitidart.  If you notice any more problems, please don't hesitate to file more bugs.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Whiteboard: fixed by bug 669475
Target Milestone: --- → 1.1
(Reporter)

Comment 6

7 years ago
My pleasure I cant wait to see builder out nice and perfect :)
You need to log in before you can comment on or make changes to this bug.