abort: pretxnchangegroup.c_try_mandatory hook failed

RESOLVED FIXED

Status

Release Engineering
Other
RESOLVED FIXED
6 years ago
3 years ago

People

(Reporter: surkov, Assigned: lsblakk)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: tryserver)

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Can't push on try, log:

pushing to ssh://hg.mozilla.org/try/
searching for changes
remote: adding changesets
remote: adding manifests
remote: adding file changes
remote: added 4 changesets with 4 changes to 7 files (+1 heads)
remote: To push to try you must use try syntax in your push comment 
remote: See http://people.mozilla.org/~lsblakk/trychooser/ to build your syntax
remote: For assistance using the syntax and https://wiki.mozilla.org/Build:TryChooser for more information.
remote: Thank you for helping to reduce CPU cyles by asking for exactly what you need.
remote: transaction abort!
remote: rollback completed
remote: abort: pretxnchangegroup.c_try_mandatory hook failed
abort: unexpected response: empty string

Any idea what can be wrong?
(Assignee)

Comment 1

6 years ago
Did your push have try syntax in the push commit comments?
(Assignee)

Updated

6 years ago
Assignee: nobody → lsblakk
(Reporter)

Comment 2

6 years ago
(In reply to comment #1)
> Did your push have try syntax in the push commit comments?

I tried both. Got the same result for "try: -u mochitest-o" syntax and for no syntax.
Could you paste the response to 'hg out' ? (with whatever you use to select try)
(Reporter)

Comment 4

6 years ago
Just tried to push again and it works, though the queue was changed. hg out that I tried to push was:
changeset:   72615:f08daae8b303
tag:         669130
tag:         qtip
tag:         tip
user:        Ginn Chen <ginn.chen@oracle.com>
date:        Thu Jul 14 00:27:06 2011 +0900
summary:     Bug 669130 - [atk] Page setup dialog is not added to Firefox a11y tree, r=surkov, tbsaunde, roc

changeset:   72614:4f8b04dbcd79
tag:         669253
user:        Ginn Chen <ginn.chen@oracle.com>
date:        Tue Jul 12 17:04:22 2011 +0900
summary:     Bug 669253 - When print dialog popup/close, get GLib-GObject-WARNING **: gsignal.c:2924: signal id 'xxx' is invalid for instance 'xxxxxxxx', r=fer

changeset:   72613:b01765479540
tag:         670870
user:        Ginn Chen <ginn.chen@oracle.com>
date:        Tue Jul 12 16:57:36 2011 +0900
summary:     Bug 669253 - When print dialog popup/close, get GLib-GObject-WARNING **: gsignal.c:2924: signal id 'xxx' is invalid for instance 'xxxxxxxx', r=fer

changeset:   72612:6dd621875c79
tag:         649236
tag:         qbase
user:        Alexander Surkov <surkov.alexander@gmail.com>
date:        Tue Jul 12 16:23:08 2011 +0900
summary:     try: -u mochitest-o

so two changesets have same summary, I'm not sure if that was a problem.

close as worksforme?
I think the issue is that your 'try: ' string isn't in the tipmost change (72615). The ordering of your mq might need changing.

lsblakk, perhaps we should change the hook output to (eg)
  To push to try you must use try syntax in the push comment of the *last* change
(Assignee)

Comment 6

6 years ago
Created attachment 548268 [details] [diff] [review]
update try hook output to let people know which commit needs to have the syntax
Attachment #548268 - Flags: review?(nrthomas)
Attachment #548268 - Flags: review?(nrthomas) → review+
(Assignee)

Comment 7

6 years ago
requested a hook refresh server-side in bug 662755
(Assignee)

Comment 8

6 years ago
Comment on attachment 548268 [details] [diff] [review]
update try hook output to let people know which commit needs to have the syntax

http://hg.mozilla.org/hgcustom/hghooks/rev/8a2272cb0fac
Attachment #548268 - Flags: checked-in+
(Assignee)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering

Comment 9

3 years ago
https://hg.mozilla.org/hgcustom/version-control-tools/rev/816d60dea63b
You need to log in before you can comment on or make changes to this bug.