Searching by GUID is not supported

RESOLVED WONTFIX

Status

addons.mozilla.org Graveyard
Search
RESOLVED WONTFIX
7 years ago
2 years ago

People

(Reporter: krupa, Assigned: jbalogh)

Tracking

unspecified
6.1.6

Details

(URL)

(Reporter)

Description

7 years ago
steps to reproduce:
1. Search for guid:krups@krups.com or guid:{9AB56F4F-4EC8-5e97-97AF-5336180634FE}

expected behavior:
Search finds add-ons which match that GUID
https://addons.allizom.org/z/en-US/firefox/search/?q=guid%3Akrups%40krups.com&cat=all&x=19&y=17 and 
https://addons.allizom.org/z/en-US/firefox/search/?q=guid%3A{9AB56F4F-4EC8-5e97-97AF-5336180634FE}&cat=all&x=0&y=0 respectively


observed behavior:
Search doesn't return any results since searching by GUID is not supported
(Assignee)

Comment 1

7 years ago
This has been used exactly zero times this month. What's the point?
(Assignee)

Comment 2

7 years ago
(In reply to comment #1)
> This has been used exactly zero times this month. What's the point?

Alright then. GUID search is still available from the API.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 3

7 years ago
fligtar, are you okay with this?
(In reply to krupa raj 82[:krupa] from comment #3)
> fligtar, are you okay with this?

I didn't actually know search supported GUIDs or I'd be using it. Right now I do DB queries for this and when other people ask I direct them to the API. Had I known search supported GUIDs I would have been using it much more.
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.