Closed Bug 671477 Opened 9 years ago Closed 8 years ago

Mozmill Endurance test for loading a SWF video via embed

Categories

(Mozilla QA Graveyard :: Mozmill Tests, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: u279076, Assigned: remus.pop)

References

()

Details

(Whiteboard: [mozmill-endurance])

Attachments

(1 file, 3 obsolete files)

Create a Mozmill Endurance test for loading an SWF video embedded into a webpage using the <embed> tag.

See http://kb2.adobe.com/cps/127/tn_12701.html for more info.
For consistency, please use a width of 640 and a height of 480.
Assignee: nobody → vlad.maniac
Status: NEW → ASSIGNED
A Pivotal Tracker story has been created for this Bug: https://www.pivotaltracker.com/story/show/16294941
FYI - Once bug 671476 is fixed I will immediately propose a patch here 

The approach is similar for both tests
Depends on: 671476
Assignee: vlad.mozbugs → remus.pop
Attached patch patch v1 (obsolete) — Splinter Review
Original code is in bug 671476 and only modified the page it loads.
Attachment #576769 - Flags: review?(vlad.mozbugs)
Comment on attachment 576769 [details] [diff] [review]
patch v1


>+var tabs = require("../../../lib/tabs");
>+
>+const TEST_DOMAIN = "http://www.mozqa.com/";
>+const TEST_PAGE = TEST_DOMAIN + "data/firefox/plugins/flash/test_flv_embed.html";

this is referring the old flv video in the html page. perhaps its a good idea to change 
it with the new ones - the 10 second considerably smaller videos. 

Remus, please file a bug and I'll make the changes

Until then, cancelling review
Attachment #576769 - Flags: review?(vlad.mozbugs)
(In reply to Maniac Vlad Florin (:vladmaniac) from comment #5)
> Remus, please file a bug and I'll make the changes
Logged bug 705238 as I need those files changed for some of my tests
Depends on: 705238
Depends on: 708270
Comment on attachment 576769 [details] [diff] [review]
patch v1

Dependency has been solved.
Attachment #576769 - Flags: review?(vlad.mozbugs)
Comment on attachment 576769 [details] [diff] [review]
patch v1

code wise it's fine 

does not fail locally 

+ from me 

sending to Anthony
Attachment #576769 - Flags: review?(vlad.mozbugs)
Attachment #576769 - Flags: review?(anthony.s.hughes)
Attachment #576769 - Flags: review+
The name for the test method is testFlashURL. Should it not indicate that we're testing flash via an embed tag rather than via the URL?
Attached patch patch v2 (obsolete) — Splinter Review
You're right, Dave. Here's the fix.
Attachment #576769 - Attachment is obsolete: true
Attachment #580889 - Flags: review?(anthony.s.hughes)
Attachment #576769 - Flags: review?(anthony.s.hughes)
Comment on attachment 580889 [details] [diff] [review]
patch v2

>+/*
>+ * Test opening embeded flash content
>+ */

Small nit: "embedded" - fix this everywhere

>+function testFlashViaEmbedTag() {

testSWFViaEmbed() {

>+      enduranceManager.addCheckpoint("Web page has been loaded"); 
>+    });
>+    // Close all tabs
>+    tabBrowser.closeAllTabs();
>+  });

Separate these code blocks with a newline
Attachment #580889 - Flags: review?(anthony.s.hughes) → review-
Depends on: 717636
Comment on attachment 580889 [details] [diff] [review]
patch v2

>+const TEST_DOMAIN = "http://www.mozqa.com/";
>+const TEST_PAGE = TEST_DOMAIN + "data/firefox/plugins/flash/test_flv_embed.html";

You're using the test file for FLV here, you need to use the one for SWF, after bug 717636 lands.
Attached patch patch v3 (all branches) (obsolete) — Splinter Review
Fixed to load the correct flash content.
Attachment #580889 - Attachment is obsolete: true
Attachment #597021 - Flags: review?(anthony.s.hughes)
Comment on attachment 597021 [details] [diff] [review]
patch v3 (all branches)

>+ * The Initial Developer of the Original Code is the Mozilla Foundation.
>+ * Portions created by the Initial Developer are Copyright (C) 2011
>+ * the Initial Developer. All Rights Reserved.

2012

>+    });
>+    // Close all tabs
>+    tabBrowser.closeAllTabs();
>+  });
>+}

Add some spacing in here.

Assuming these two nits are addressed, I think this is okay to land.

Adding Dave Hunt for some feedback.
Attachment #597021 - Flags: review?(anthony.s.hughes)
Attachment #597021 - Flags: review-
Attachment #597021 - Flags: feedback?(dave.hunt)
Comment on attachment 597021 [details] [diff] [review]
patch v3 (all branches)

With the nits addressed, this looks good.
Attachment #597021 - Flags: feedback?(dave.hunt) → feedback+
Attached patch test v4 [landed]Splinter Review
Nits addressed.
Attachment #597021 - Attachment is obsolete: true
Attachment #597374 - Flags: review?(anthony.s.hughes)
Comment on attachment 597374 [details] [diff] [review]
test v4 [landed]

Looks good to me. Landing on default.
Attachment #597374 - Flags: review?(anthony.s.hughes) → review+
Comment on attachment 597374 [details] [diff] [review]
test v4 [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/8286c25c8978 (default)
Attachment #597374 - Attachment description: patch v4 (all branches) → patch v4 [landed:default]
Please check the next testruns to ensure no regressions and I will port this to other branches.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
(In reply to Anthony Hughes, Mozilla QA (irc: ashughes) from comment #19)
> Please check the next testruns to ensure no regressions and I will port this
> to other branches.

Remus, any update on this?
Test hasn't failed on default since checkin so it can land on the other branches.
Comment on attachment 597374 [details] [diff] [review]
test v4 [landed]

Landed:
http://hg.mozilla.org/qa/mozmill-tests/rev/18b278f863fb (mozilla-aurora)
http://hg.mozilla.org/qa/mozmill-tests/rev/afd627d3e9d8 (mozilla-beta)
http://hg.mozilla.org/qa/mozmill-tests/rev/96631ff48342 (mozilla-release)
Attachment #597374 - Attachment description: patch v4 [landed:default] → test v4 [landed]
Status: RESOLVED → VERIFIED
Product: Mozilla QA → Mozilla QA Graveyard
You need to log in before you can comment on or make changes to this bug.