Closed Bug 671512 Opened 9 years ago Closed 9 months ago

Preferences/Beta tab content is missing if Fennec performs a downloading action before it loads for the first time

Categories

(Firefox for Android Graveyard :: General, defect, P5)

Firefox 6
ARM
Android
defect

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: xti, Unassigned)

Details

(Whiteboard: [fennec 6.0b2] DUPEME)

Attachments

(1 file)

Attached image screenshot
Build id : Mozilla/5.0 (Android;Linux armv7l;rv:6.0)Gecko/20110713
Firefox/6.0 Fennec/6.0
Device: Motorola Droid 2
OS: Android 2.2

Steps to reproduce:
1. Install Firefox 6 Beta build (do not open app after it has been installed)
2. Open the stock browser
3. Browse to http://ftp.mozilla.org/pub/mozilla.org/mobile/nightly/latest-mozilla-central-android-r7/
4. Tap on fennec-8.0a1.multi.eabi-arm.apk
5. Choose from the "Complete actions using" list Firefox Beta app
6. After the app opens, go to Preferences > Beta tab

Expected result:
After step 6, user will be able to give a feedback, to find more info about this beta, to force add-ons compatibility or to enable the Error Console.

Actual result:
Beta tab content is missing and a grey background will cover the tab area.

Note:
This issue doesn't occur if:
- instead of step 4, a link will be opened with Firefox Beta.
- after making some browsing, I've cleared the Firefox Beta's data from Android System and reopening the app, Beta tab was displayed as expected.
Whiteboard: [fennec 6.0b2]
Whiteboard: [fennec 6.0b2] → [fennec 6.0b2] DUPEME
Just trying to understand the steps... is it suppose to be fennec-8.0a1.multi.eabi-arm.apk in step 4?
(In reply to comment #1)
> Just trying to understand the steps... is it suppose to be
> fennec-8.0a1.multi.eabi-arm.apk in step 4?

The idea at step 4 is to download any file through to Beta build
Priority: -- → P5
Closing all opened bug in a graveyard component
Status: NEW → RESOLVED
Closed: 9 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.