Closed Bug 671691 Opened 9 years ago Closed 6 years ago

setting window.crypto.x disappears after gc

Categories

(Core :: DOM: Core & HTML, defect)

7 Branch
All
Other
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: felix8a, Unassigned)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

859 bytes, text/plain
Details
Attached file a.html
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0a2) Gecko/20110713 Firefox/7.0a2
Build ID: 20110713042002

Steps to reproduce:

If I set properties on the window.crypto object, my changes disappear at some arbitrary time, probably after a GC.

Load the attached "a.html" in a firefox browser.

Click "generate garbage" a few times.
Eventually the result will be "crypto.x = undefined".

Clicking "ref crypto" will keep a reference to window.crypto, and doing that will prevent the disappearing value.

I tested this in Aurora 7.0a2 (2011-07-13)
Forgot to mention, this bug was found by Emily Stark.  I just isolated it into a small testcase.
This is the case for most DOM objects.  DOM nodes are special-cased to preserve the wrapper when expandos are added....

I believe there are no plans to change this until new DOM bindings land.
Whiteboard: DUPEME
See Also: → 673468
See Also: → 655297
IIRC, the new bindings for window.crypto landed, and I can not reproduce with the attached testcase.
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: DUPEME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.