Closed Bug 671746 Opened 9 years ago Closed 9 years ago

deoptimized 6.0b1/win32/en-US omni.jar can not be opened by 7-zip, is likely not a strictly valid zip archive

Categories

(Firefox Build System :: General, defect)

6 Branch
x86
Windows XP
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 684957

People

(Reporter: al_9x, Unassigned)

Details

omni.jar source: https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/6.0b1/win32/en-US/Firefox%20Setup%206.0b1.exe

original omni.jar sha1: bc371bc910b3dd3f18e8cca4b2c654444cd497ea

optimizejars.py source: https://hg.mozilla.org/releases/mozilla-beta/raw-file/FIREFOX_6_0b1_RELEASE/config/optimizejars.py

optimizejars.py sha1: d205b35ea5651c9ed7d0b3d1d2ebfd8a7bacd4b7

deoptimized omni.jar sha1: 106dd900a4abf69b8387fd1a730e1a2cd71db2a4

7-zip version: 9.22

7-zip error: Can not open file '<path>\omni.jar' as archive

this works in 5.0
This is likely a valid bug. I wonder which part of the zip is confusing it. I haven't seen this with other zip programs. Do winrar/winzip/etc open it without complaints?
(In reply to comment #1)
> Do winrar/winzip/etc open it
> without complaints?

Winrar and native windows zip folders do, but they open the optimized original too, they are much looser than 7-zip, which as you know, demands strict conformance.
(In reply to comment #1)
> I wonder which part of the zip is confusing it.

Winrar repair will rebuild the archive properly, then you can diff.
This is by design. It's also a dupe of bug 595473.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 595473
Whoops, missed comment #1. Sorry. That said, I recall that this was done by design, but I can't find the specific comment.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: DUPLICATE → ---
(In reply to comment #5)
> I recall that this was done by
> design, but I can't find the specific comment.

What was done by design?  Note, that this bug is about deoptimzed jars.
Sorry, complete fail on my part.
Status: REOPENED → NEW
(In reply to comment #3)
> (In reply to comment #1)
> > I wonder which part of the zip is confusing it.
> 
> Winrar repair will rebuild the archive properly, then you can diff.

Any progress?
Opps, I just opened bug 684957 which is a dupe of this one. That one has a patch though so I'm duping in the other direction.

(I *knew* there was a bug.. just couldn't find it..)
Status: NEW → RESOLVED
Closed: 9 years ago9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 684957
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.