drag link/proxy icon to sidebar tab to insert new panel

NEW
Unassigned

Status

--
enhancement
18 years ago
7 years ago

People

(Reporter: jruderman, Unassigned)

Tracking

({helpwanted})

Trunk
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

18 years ago
From mpt@mailandnews.com in bug 50063:

>You should be able to drag a link/URL to the tabs (as opposed to the 
>sidebar content) in the open sidebar, to create a tab in the position you drop 
>the URL.

Neat idea.  Dragging to tabs or to the top of the sidebar (above the first tab) 
should give an "Add to sidebar?" dialog.

Should the user also be given a chance to specify a title for the new panel?  
Many webpage titles aren't designed to be used as sidebar panel titles.

Comment 1

18 years ago
> Dragging to tabs or to the top of the sidebar (above the first tab)
> should give an "Add to sidebar?" dialog.

Right.

> Should the user also be given a chance to specify a title for the new panel?

Yes. IMO, this should be added to the "Add to sidebar?" confirmation dialog,
since the user might not like the title of a specifially designed sidebar panel
either. It should have the author-specified title as default, tough.
(Or is there a way to change the title afterwards? I haven't found one quickly.)

Comment 2

18 years ago
You have the same problem as you have in bookmarks -- a tradeoff between the 
convenience of adding an item quickly (without a dialog), and being able to 
edit details when adding it (by using a dialog). See also bug 47599.

Comment 3

18 years ago
We need a dialog anyways, for confirmation.

Comment 4

18 years ago
Adding a panel via window.sidebar.addPanel always requests confirmation, but 
does not give the ability to change the title.

Comment 5

18 years ago
Created attachment 24304 [details] [diff] [review]
Proposed patch

Comment 6

18 years ago
The above patch should allow you to drag a URL to the "My Sidebar" tab at the
top of the sidebar panel. It will then be added (after confirmation).

Cc'ing ben, because a lot of the current drag and drop code has "XXX - WARNING -
XXX" comments in it.

Comment 7

18 years ago
The attached patch does not seem to work any longer.

Comment 8

18 years ago
Created attachment 32866 [details] [diff] [review]
Revised patch

Comment 9

18 years ago
Created attachment 32867 [details] [diff] [review]
Revised patch again (text/javascript should be application/x-javascript)

Comment 10

18 years ago
in olden times, <a href=foo>was</a> valid.  a quick read of your code indicates 
you don't like it.

<a href="http://foo/bar'baz/"> also appears to be squished

Comment 11

18 years ago
Good point (not to mention <a target="whatever" href="url"> and others...) But
at the moment I can't find anything to drag which gives a flavour of text/html,
so that code isn't being executed. (Dragging from the main content window is
giving me text/x-moz-url). So unless anyone can tell me how to do this, I will
submit a revised patch without this section of code.

Comment 12

17 years ago
Cool feature.  Todd, German, what do you'll think?  Would this be a high
priority for Netscape to contribute?
Assignee: matt → sgehani

Comment 13

17 years ago
This does sound pretty cool, but not a priority, IMO.  Many users never fully
discover DnD functionality and this would be a relatively complex concept for
the average end user to understand.  We could do some things to help them, but
we need to focus our efforts for now on more basic improvements to Sidebar
behavior/functionality.  That's my 2 cents anyway.

Comment 14

17 years ago
Just to note that this patch no longer works correctly.

Updated

17 years ago
Keywords: helpwanted
Target Milestone: --- → Future

Comment 15

17 years ago
Trying again, it seems to work OK in an optimised build, but there are some
nasty assertions in a debug build.

Updated

17 years ago
Attachment #24304 - Attachment is obsolete: true

Updated

17 years ago
Attachment #32866 - Attachment is obsolete: true

Updated

16 years ago
Summary: [rfe] drag link/proxy icon to sidebar tab to insert new panel → drag link/proxy icon to sidebar tab to insert new panel
Product: Browser → Seamonkey
Assignee: samir_bugzilla → nobody
QA Contact: sujay → sidebar
Target Milestone: Future → ---

Comment 16

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614
Status: NEW → UNCONFIRMED

Comment 17

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 18

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 19

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 20

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 21

10 years ago
This bug report is registered in the SeaMonkey product, but has been without a comment since the inception of the SeaMonkey project. This means that it was logged against the old Mozilla suite and we cannot determine that it's still valid for the current SeaMonkey suite. Because of this, we are setting it to an UNCONFIRMED state.

If you can confirm that this report still applies to current SeaMonkey 2.x nightly builds, please set it back to the NEW state along with a comment on how you reproduced it on what Build ID, or if it's an enhancement request, why it's still worth implementing and in what way.
If you can confirm that the report doesn't apply to current SeaMonkey 2.x nightly builds, please set it to the appropriate RESOLVED state (WORKSFORME, INVALID, WONTFIX, or similar).
If no action happens within the next few months, we move this bug report to an EXPIRED state.

Query tag for this change: mass-UNCONFIRM-20090614

Comment 22

9 years ago
MASS-CHANGE:
This bug report is registered in the SeaMonkey product, but still has no comment since the inception of the SeaMonkey project 5 years ago.

Because of this, we're resolving the bug as EXPIRED.

If you still can reproduce the bug on SeaMonkey 2 or otherwise think it's still valid, please REOPEN it and if it is a platform or toolkit issue, move it to the according component.

Query tag for this change: EXPIRED-20100420
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → EXPIRED

Updated

7 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: EXPIRED → ---

Comment 23

7 years ago
Valid RFE.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 98 → All
Hardware: x86 → All
You need to log in before you can comment on or make changes to this bug.