Last Comment Bug 671796 - "ASSERTION: unexpected block frame" with text-overflow, overflow, mathml
: "ASSERTION: unexpected block frame" with text-overflow, overflow, mathml
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Layout (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla8
Assigned To: Mats Palmgren (:mats)
:
Mentors:
Depends on:
Blocks: randomstyles
  Show dependency treegraph
 
Reported: 2011-07-14 23:02 PDT by Jesse Ruderman
Modified: 2011-07-19 12:11 PDT (History)
4 users (show)
mats: in‑testsuite+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (223 bytes, application/xhtml+xml)
2011-07-14 23:02 PDT, Jesse Ruderman
no flags Details
stack trace (6.31 KB, text/plain)
2011-07-14 23:04 PDT, Jesse Ruderman
no flags Details
frame dump (4.76 KB, text/html)
2011-07-15 07:54 PDT, Mats Palmgren (:mats)
no flags Details
fix (1.09 KB, patch)
2011-07-15 08:01 PDT, Mats Palmgren (:mats)
no flags Details | Diff | Review
test (1.22 KB, patch)
2011-07-15 08:02 PDT, Mats Palmgren (:mats)
roc: review+
Details | Diff | Review
fix v2 (1.15 KB, patch)
2011-07-15 13:40 PDT, Mats Palmgren (:mats)
roc: review+
Details | Diff | Review

Description Jesse Ruderman 2011-07-14 23:02:45 PDT
Created attachment 546100 [details]
testcase

###!!! ASSERTION: unexpected block frame: '!aFrame->GetStyleDisplay()->IsBlockOutside()', file layout/generic/TextOverflow.cpp, line 89
Comment 1 Jesse Ruderman 2011-07-14 23:04:05 PDT
Created attachment 546101 [details]
stack trace
Comment 2 Mats Palmgren (:mats) 2011-07-15 07:54:26 PDT
Created attachment 546157 [details]
frame dump

The assertion is a false positive.  The frame class is nsMathMLmsupFrame.
Comment 3 Mats Palmgren (:mats) 2011-07-15 08:01:29 PDT
Created attachment 546160 [details] [diff] [review]
fix

Let's not use style data here, since it's ignored by frame construction
in some cases.  Test the actual frame class instead.
Comment 4 Mats Palmgren (:mats) 2011-07-15 08:02:12 PDT
Created attachment 546161 [details] [diff] [review]
test
Comment 5 Mats Palmgren (:mats) 2011-07-15 09:48:32 PDT
Comment on attachment 546160 [details] [diff] [review]
fix

Hmm, this triggered the assertion for other tests on Try, investigating...
Comment 6 Mats Palmgren (:mats) 2011-07-15 13:40:11 PDT
Created attachment 546218 [details] [diff] [review]
fix v2

The assertions came from 
1. display:inline-block  
2. ComboboxControl(select)
so testing both GetAsBlock() and IsBlockOutside() should work.
Comment 7 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-15 13:52:23 PDT
Comment on attachment 546218 [details] [diff] [review]
fix v2

Review of attachment 546218 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 8 Robert O'Callahan (:roc) (Exited; email my personal email if necessary) 2011-07-15 13:52:30 PDT
Comment on attachment 546161 [details] [diff] [review]
test

Review of attachment 546161 [details] [diff] [review]:
-----------------------------------------------------------------
Comment 10 Joe Drew (not getting mail) 2011-07-16 18:48:01 PDT
This (along with most things committed on Friday afternoon) was backed out of mozilla-inbound in order to clear up orange.
Comment 12 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-19 12:11:22 PDT
http://hg.mozilla.org/mozilla-central/rev/42e4a85bcb2d
Comment 13 :Ehsan Akhgari (busy, don't ask for review please) 2011-07-19 12:11:38 PDT
Also: http://hg.mozilla.org/mozilla-central/rev/7da298066377

Note You need to log in before you can comment on or make changes to this bug.