Thunderbird 5 on Mac OS X hangs with enigmail

RESOLVED INVALID

Status

Thunderbird
General
--
critical
RESOLVED INVALID
7 years ago
7 years ago

People

(Reporter: Markus Multrus, Unassigned)

Tracking

({hang, regression, stackwanted})

x86
Mac OS X
hang, regression, stackwanted

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 546110 [details]
process analysis (10.5.8, MacBook Pro)

Thunderbird 5.0 on Mac OS X (10.5.8, MacBook Pro) hangs from time to time. Although it happens to my basically every second day I'm not sure how to reproduce this, the only thing I can confirm is that this does not only happen directly after wake-up, but also when the program worked just fine after a wakeup. You can not close the application the normal way, but need to force quit. I never encountered this problem with any other TB version on the same OS version/hardware.

Attached is a process analysis, generated with the Mac OS X generic process monitor, I hope this helps...
(In reply to comment #0)

> Attached is a process analysis, generated with the Mac OS X generic process
> monitor, I hope this helps...

Yeah it show that we are waiting on semaphores. 

Does it also happens in -safe-mode (see http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ? 

A stack with complete symbols would be more useful , but we would need you to run a debug build, would you be willing to do that ?
Severity: normal → major
Keywords: hang
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> (In reply to comment #0)
> Does it also happens in -safe-mode (see
> http://support.mozillamessaging.com/en-US/kb/Safe-Mode) ? 

I'll give it a try and report back. Might need some time since I can not reproduce this on command.

> A stack with complete symbols would be more useful , but we would need you
> to run a debug build, would you be willing to do that ?

I can also do this, but you need to provide me with a ready-to-run debug build. I don't want to build myself... ;-)

Updated

7 years ago
Severity: major → critical

Comment 3

7 years ago
(In reply to comment #2)
> (In reply to comment #1)
> > A stack with complete symbols would be more useful , but we would need you
> > to run a debug build, would you be willing to do that ?
> 
> I can also do this, but you need to provide me with a ready-to-run debug
> build. I don't want to build myself... ;-)

can Mark or Andrew get a debug build for Markus?  (unless it's deemed not needed)


Markus, 
Did this start with version 5, and not happen in version 3?
If you have addons, does it happen when started in safe mode?
Keywords: stackwanted
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> can Mark or Andrew get a debug build for Markus?  (unless it's deemed not
> needed)

Wait a moment before you do this. I had it running last week without any hang, and I disabled the Enigmal Addon. I will enable this again next week, and try to reproduce.

> Markus, 
> Did this start with version 5, and not happen in version 3?

I never had these Problems with version, with the exact same set of Addons installed. 

> If you have addons, does it happen when started in safe mode?

As written above, I'll try to find out whether this is Add-on related or not. I would propose not to take any action on this until I know more...
Mac nightly builds (e.g. Earlybird or Shredder) have debug symbols by default.
(Reporter)

Comment 6

7 years ago
OK, I can now reproduce this halfway reliably with the following two add-ons installed:

- Enigmail 1.2
- FoxClocks 2.9.35

With only one of them, everything seems to work fine. The trouble only starts of both of them are active.

Does it still make sense to check this with a debug-build of TB, or is this useless, since probably neither Enigmail not FoxClocks includes symbols?

Comment 7

7 years ago
(In reply to Markus Multrus from comment #6)
> Does it still make sense to check this with a debug-build of TB, or is this
> useless, since probably neither Enigmail not FoxClocks includes symbols?

Markus, you'd want to contact the authors of these addons.

FWIW, enigmail has been known to cause hangs. see https://bugzilla.mozilla.org/buglist.cgi?type1-0-0=substring&keywords=hang&keywords_type=allwords&list_id=979695&short_desc=Enigmail%20&field0-0-0=short_desc&type0-0-1=substring&field0-0-1=keywords&type1-0-1=allwordssubstr&classification=Client%20Software&classification=Components&query_format=advanced&short_desc_type=allwordssubstr&type0-0-0=anywordssubstr&field1-0-0=short_desc&product=MailNews%20Core&product=Thunderbird&field1-0-1=short_desc
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Keywords: regression
Resolution: --- → INVALID
Summary: Thunderbird 5 on Mac OS X hangs → Thunderbird 5 on Mac OS X hangs with enigmail
You need to log in before you can comment on or make changes to this bug.