Thunderbird 5.0 Attachments (base64 encoded) of IMAP mails not shown

RESOLVED DUPLICATE of bug 602718

Status

--
major
RESOLVED DUPLICATE of bug 602718
8 years ago
7 years ago

People

(Reporter: n3on, Unassigned)

Tracking

x86_64
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has 1/2 a test case])

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Received a mail on my IMAP mail-post (hosted on an exchange server 2007) that contains an attachement. verified on outlook web access that the attachment really was there.


Actual results:

attachment neighter shown on messages folder overview nor when message opened


Expected results:

attachment should have be shown
(Reporter)

Updated

8 years ago
Severity: normal → major
OS: Other → Windows 7
Hardware: All → x86_64
is the attachment visible if you view the source of the message ?
(Reporter)

Comment 2

7 years ago
Yes, the attachment is vissible in the source of the msg.

--_002_D9D750BA9E3144AEB04168C543664E2Aabcdef_
Content-Type: application/pdf; name="table.excel.pdf"
Content-Description: table.excel.pdf
Content-Disposition: inline; filename="table.excel.pdf"; size=32308;
	creation-date="Fri, 15 Jul 2011 09:52:16 GMT";
	modification-date="Fri, 15 Jul 2011 09:52:16 GMT"
Content-ID: <0af571ad-285e-482e-b3e6-c0ada10c1433@abc.def>
Content-Transfer-Encoding: base64

// crypted content

--_002_D9D750BA9E3144AEB04168C543664E2Akitedu_--
Component: General → MIME
Product: Thunderbird → MailNews Core
QA Contact: general → mime
Summary: Thunderbird 5.0 Attachments of IMAP mails not shown → Thunderbird 5.0 Attachments (base64 encoded) of IMAP mails not shown
Whiteboard: [has 1/2 a test case]

Comment 3

7 years ago
Can you scroll a little up in that message and figure out if the PDF attachment is in a "Content-Type: multipart/mixed" or "Content-Type: multipart/related" context? If the latter, this should be covered by bug 602718.
(Reporter)

Comment 4

7 years ago
Don't know if it's what you where talking about, but seem's to be the latter:

...
Content-Type: multipart/related;
	boundary="_002_D9D750BA9E3144AEB04168C543664E2Aabcdef_"; type="text/html"
MIME-Version: 1.0

--_002_D9D750BA9E3144AEB04168C543664E2Aabcdef_
Content-Type: text/html; charset="utf-8"
Content-Transfer-Encoding: base64

// crypted content of the message body

--_002_D9D750BA9E3144AEB04168C543664E2Aabcdef_
Content-Type: application/pdf; name="table.excel.pdf"
Content-Description: table.excel.pdf
Content-Disposition: inline; filename="table.excel.pdf"; size=32308;
	creation-date="Fri, 15 Jul 2011 09:52:16 GMT";
	modification-date="Fri, 15 Jul 2011 09:52:16 GMT"
Content-ID: <0af571ad-285e-482e-b3e6-c0ada10c1433@abc.def>
Content-Transfer-Encoding: base64

// crypted content

--_002_D9D750BA9E3144AEB04168C543664E2Akitedu_--

Comment 5

7 years ago
Yes, this corresponds to the other cases of malformed messages which could be resolved by the "Show all message parts" option proposed in that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 602718
You need to log in before you can comment on or make changes to this bug.