JS Console doesn't wrap long lines

RESOLVED WORKSFORME

Status

()

--
trivial
RESOLVED WORKSFORME
18 years ago
18 years ago

People

(Reporter: neil, Assigned: trudelle)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: worksforme?, URL)

(Reporter)

Description

18 years ago
In Netscape 6 the JS Console wraps long lines (very useful because exceptions
are usually quite long). Mozilla doesn't seem to do this any more.

Comment 1

18 years ago
Confirmed using Mozilla binary 20010125xx on WinNT. 

Loading the URL produces a DOM error in the JavaScript console. 
If you re-size the JS console window to be small, and keep re-loading 
this URL, the error message doesn't wrap and gets cut off - 
and you don't get a horizontal scrollbar.

I believe this was mccabe's area. Per recent reassignment plan,
sending to Patrick. CC'ing jband in case he is interested in this,
or knows who is the best person for this bug -   
Assignee: rogerl → beard

Comment 2

18 years ago
Using Mozilla binary 2001012608 on Linux. Same problem. 
Changing OS to "All". 

Neil, do you have any URLs that produce long error messages?
If you do, could you mention them below? Thanks - 

It occurs to me that since this bug concerns the GUI interface
of the JS Console, rather than its content, it may belong to 
XP Toolkit/Widgets rather than JS Engine. Reassigning -

If I am wrong about this, please reassign back - thanks.
Assignee: beard → trudelle
Component: Javascript Engine → XP Toolkit/Widgets
OS: Windows 95 → All
QA Contact: pschwartau → jrgm

Comment 3

18 years ago
The lines wrap, classic or modern skin, on win2k, with a Jan31 build, and
scrollbars appear as required.

But it's not really a toolkit bug (unless there is a particular place where 
the tree is not functioning correctly, but I don't see one). 

Who owns the XUL for the JS Console app now?

Updated

18 years ago
Summary: [REGRESSION] JS Console doesn't wrap long lines → JS Console doesn't wrap long lines
Whiteboard: worksforme?
(Reporter)

Comment 4

18 years ago
Confiming as skin-dependant. Surely .treecell-error { white-space: normal }
should be in chrome://global/content/console.css not chrome://global/skin.css?

Comment 5

18 years ago
Using Mozilla binaries 20010201xx on Linux, WinNT. No matter what skin 
I try (Classic, Modern, Blue) I still see a difference in the horizontal 
vs. vertical behavior of the JavaScript console, on both platforms. 


If I fill the console full of errors, and then resize its window to be
too small for the text, here's what I see:


VERT: a vertical scrollbar appears the instant it's necessary - perfect.

HORIZ: text wraps as you shrink the window, until a certain point when it 
"gives up". At this point we would expect a horizontal scrollbar to appear, 
but it never does (for me). Text is then lost out of view. 

Comment 6

18 years ago
cc'ing Joe Hewitt due to his fine work on bug 67647. 
Joe, would you know who should own this bug? Thanks - 


Question for neil@parkwaycc.co.uk:  I do see long lines wrap 
in the JS Console, but no horizontal scrollbar if the console window 
is reduced to a really small size. So should we change the summary 
of this bug from 

                "JS Console doesn't wrap long lines"
to              "JS Console doesn't produce horizontal scrollbar"   ?



Or do you still see no wrapping at all? Also - what build ID, and what skin 
are you using when the problem occurs? Thanks - 

Comment 7

18 years ago
After making all the changes I did in bug 67647, I do see horizontal scrollbars
appearing now.  
(Reporter)

Comment 8

18 years ago
I was using a non-Mozilla skin, so its console.css was not sufficiently current.
(Assignee)

Comment 9

18 years ago
resolving as wfm
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.