Select boxes do not show focus by click or javascript.focus() until reached with tab

RESOLVED INVALID

Status

()

RESOLVED INVALID
8 years ago
8 years ago

People

(Reporter: ttrask01, Unassigned)

Tracking

5 Branch
All
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17) Gecko/20110422 Ubuntu/10.04 (lucid) Firefox/3.6.17
Build ID: 20110422054454

Steps to reproduce:

In any html page with a <select> field, the select field will receive focus, but not display it (with shaded box) until reached by tab (or shift-tab). Example code:

<select id="test1"><option selected value="1">1</option></select>
<input class="text" type="text" value="" id="test2">
<input class="submit" type=button value="Select" onClick="document.getElementById('test1').focus() ">
<input class="submit" type=button value="Text" onClick="document.getElementById('test2').focus() ">

If you click on the text input or the Text button, focus is shown on the text input (the caret is visible). If you click on the select box or the Select button, focus is not shown on the select box. Once you hit tab (or shift tab) to reach the select box, focus is visible and works properly via tab, click, or javascript.


Actual results:

Focus on the select box was not visible.


Expected results:

Focus on the select box should have been visible (with shaded box)
Created attachment 546164 [details]
Reporter's testcase
The test works fine for me in Fx5 (using a fresh profile) on Ubuntu 11.04.

Ted, can you reproduce the problem using a fresh profile, for example:
# mkdir /tmp/profile
# firefox -no-remote -profile /tmp/profile
(Reporter)

Comment 3

8 years ago
I have reproduced the bug on Windows XP and Windows 7 with fresh installs of 5.0. I just reproduced it again on Windows Vista with a fresh install of 5.0.1. I'll try it on Ubuntu in a bit after burning an iso.
(Reporter)

Comment 4

8 years ago
Finally upgraded an old Ubuntu laptop to 10.04.2 and installed Firefox 5, and it worked fine. The select box was highlighted with a red box to show focus. So, this is apparently specific to Windows, but not to any specific Windows version.

I changed the Platform to Windows Vista (to pick one) because my User Agent when submitting the bug is not where I saw the bug.

FYI: Firefox 3.0.11 and 3.6.18 (the other two versions I have available) work fine on Windows XP and Windows Server 2008 R2. They all highlight the select box with a shaded box.
OS: Other → Windows Vista
Thanks for your testing.  I can reproduce the problem in Fx5 on WinXP.
The focus ring appears if I uncheck "Hide Underlined letter" in
Control Panel->Display->Appearance->Effects so I suspect it's
an effect from bug 418521. (see also bug 644479)

I suspect it's intentional, but I don't know.

Comment 7

8 years ago
This is correct behaviour on Windows depending on the setting described in comment 6. I tested it again just to make sure and it works as intended.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

8 years ago
Why should "Hide Underlined letter" have any affect on this? There are no underlined letters. And then, why does it change after you tab to the select box? Does tabbing also have an affect on underlined letters?

Comment 9

8 years ago
True, the setting's label isn't particularly descriptive, but it's behaviour in all applications is to hide and show access key underlines and focus indicators until the keyboard is used.
You need to log in before you can comment on or make changes to this bug.