Last Comment Bug 671916 - crash @ mozalloc_abort | NS_DebugBreak_P | X11Error during windowless Flash Player painting
: crash @ mozalloc_abort | NS_DebugBreak_P | X11Error during windowless Flash P...
Status: RESOLVED FIXED
: crash, regression
Product: Core
Classification: Components
Component: Plug-ins (show other bugs)
: Trunk
: All Linux
: -- critical (vote)
: mozilla8
Assigned To: Benoit Girard (:BenWa)
:
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on: 639725
Blocks: 663259
  Show dependency treegraph
 
Reported: 2011-07-15 10:58 PDT by Logan Rosen [:Logan]
Modified: 2011-08-26 04:43 PDT (History)
13 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch v1 (1.28 KB, patch)
2011-08-10 07:14 PDT, Benoit Girard (:BenWa)
cjones.bugs: review+
Details | Diff | Splinter Review

Description Logan Rosen [:Logan] 2011-07-15 10:58:09 PDT
This bug was filed from the Socorro interface and is 
report bp-3ac6f8ab-dd9e-44f7-90d7-7a2382110715 .
============================================================= 
I've now received this crash twice (see also https://crash-stats.mozilla.com/report/index/bp-4b1d89fa-103e-4c75-bff4-201f42110715).  The Flash plugin is now intermittently crashing on the latest trunk updates under Ubuntu 11.04.
Comment 1 Tanner Filip [:tanner] 2011-07-18 18:11:29 PDT
I've noticed this a lot, as well. It seems to crash for no obvious reason, even when flash isn't running. Started on July 13, maybe a regression? I'll look into a range.
Comment 2 Marcia Knous [:marcia - use ni] 2011-07-19 10:58:58 PDT
https://crash-stats.mozilla.com/report/list?signature=mozalloc_abort%20%7C%20NS_DebugBreak_P%20%7C%20X11Error

Frame 	Module 	Signature [Expand] 	Source
0 	libmozalloc.so 	mozalloc_abort 	memory/mozalloc/mozalloc_abort.cpp:66
1 	libxul.so 	NS_DebugBreak_P 	xpcom/base/nsDebugImpl.cpp:388
2 	libxul.so 	X11Error 	toolkit/xre/nsX11ErrorHandler.cpp:199
3 	libX11.so.6.3.0 	libX11.so.6.3.0@0x3b298 	
4 	libX11.so.6.3.0 	libX11.so.6.3.0@0x4192e 	
5 	libX11.so.6.3.0 	libX11.so.6.3.0@0x41fb5 	
6 	libX11.so.6.3.0 	libX11.so.6.3.0@0x35846 	
7 	libxul.so 	mozilla::plugins::PluginInstanceChild::ShowPluginFrame 	dom/plugins/ipc/PluginInstanceChild.cpp:3174
8 	libxul.so 	mozilla::plugins::PluginInstanceChild::InvalidateRectDelayed 	dom/plugins/ipc/PluginInstanceChild.cpp:3271
9 	libxul.so 	RunnableMethod<mozilla::plugins::PluginInstanceChild, void , Tuple0>::Run 	ipc/chromium/src/base/tuple.h:383
10 	libxul.so 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:342
11 	libxul.so 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:450
12 	libxul.so 	base::MessagePumpForUI::RunWithDispatcher 	ipc/chromium/src/base/message_pump_glib.cc:199
13 	libxul.so 	base::MessagePumpForUI::Run 	ipc/chromium/src/base/message_pump_glib.h:59
14 	libxul.so 	MessageLoop::Run 	ipc/chromium/src/base/message_loop.cc:218
15 	libxul.so 	XRE_InitChildProcess 	toolkit/xre/nsEmbedFunctions.cpp:510
16 	plugin-container 	main 	ipc/app/MozillaRuntimeMain.cpp:81
17 	libc-2.11.1.so 	libc-2.11.1.so@0x16bd5 	
18 	plugin-container 	plugin-container@0xe40 	
19 	plugin-container 	plugin-container@0xeff 	
20 	ld-2.11.1.so 	ld-2.11.1.so@0xe02f 	
21 	ld-2.11.1.so 	ld-2.11.1.so@0x1c8f7
Comment 3 Robert Kaiser 2011-07-19 11:59:39 PDT
This seems to happen with a whole range of Linux (kernel) versions, so it's also not a single person or distro, must be more generic.
Also, it's 8.0a1-trunk-only and first started happening on 2011-07-13 versions. Who is a Linux dev guy we could get into the loop here? Any Linux-specific checkins on the 12th or perhaps 13th that could have triggered that?
Comment 4 Marcia Knous [:marcia - use ni] 2011-07-19 16:33:00 PDT
Possible pushlog regression range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=8753de11b181&tochange=931f06b80727.

There was a merge from mozilla inbound that day.
Comment 5 Sheila Mooney 2011-07-19 16:41:14 PDT
Karl, bsmedberg, I wasn't sure who could help with this bug but dbaron suggested I cc you both. This crash started showing up on 7/13. Any ideas?
Comment 6 Robert Kaiser 2011-07-20 04:50:43 PDT
(In reply to comment #4)
> Possible pushlog regression range:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=8753de11b181&tochange=931f06b80727.

Marcia, it could also be in the next "slot" of nightly, as it's possible that those very few reports from 13th build IDs were on "hourly" builds. A looking at http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2011-07-12&enddate=2011-07-14 I see some very X11/GTK-specific changesets at the top of the list.

Ginn, could one of your changes be related?
Comment 7 Takanori MATSUURA 2011-07-26 06:31:09 PDT
It's a day when beta version of flash 11 has been released. :-)
http://labs.adobe.com/downloads/flashplayer11.html
Comment 8 Robert Kaiser 2011-07-26 06:40:31 PDT
(In reply to comment #7)
> It's a day when beta version of flash 11 has been released. :-)
> http://labs.adobe.com/downloads/flashplayer11.html

That's an interesting data point, but unfortunately doesn't explain why this happens on 8.0a1 only and not on any other versions.
Comment 9 Karl Tomlinson (back Dec 13 :karlt) 2011-07-31 18:56:13 PDT
Bug 644707 is the reason why we see this as a SIGSEGV only on 8.
Comment 10 Sheila Mooney 2011-08-04 11:32:45 PDT
We aren't getting any data about Flash versions for this one so we can't correlate it specifically to Flash 11. It's the top plugin crash on the trunk right now.
Comment 11 Logan Rosen [:Logan] 2011-08-04 13:46:20 PDT
I'm still getting this crash with Flash 10.3.181.34, so it's definitely not Flash Player 11-specific (if at all).
Comment 12 Karl Tomlinson (back Dec 13 :karlt) 2011-08-04 15:17:17 PDT
Are there any console messages to indicate the X Error?
Do you have steps to reproduce.(In reply to comment #10)

> We aren't getting any data about Flash versions

FWIW we can map the debug identifier for libflashplayer.so to versions.
Comment 13 Thomas Ahlblom 2011-08-09 16:53:04 PDT
When I try to track this down using Linux I end up in a Mac OS X bug. Anyway, this is what I've found using FlashPlayer 11.0.1.60:

bp-128a6a3b-242c-42d6-8842-c99842110809
[@ mozalloc_abort | NS_DebugBreak_P | X11Error ] 

Last good nightly: 2011-07-13
First bad nightly: 2011-07-14

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=931f06b80727&tochange=34b0b3bc6984

The first bad revision is:
changeset:   72713:5cea57e451dd
user:        Benoit Girard <b56girard@gmail.com>
date:        Tue Jul 12 10:31:18 2011 -0400
summary:     Bug 663259 - Enable Mac Async plugin by default. r=cjones,mattwoodrow

http://hg.mozilla.org/mozilla-central/rev/5cea57e451dd

-------

STR:

1. Visit http://chessinkorea.com/xe/3959 with a new, clean profile
2. Shake the right scroll bar fast for 20 seconds

Actual Results:
FlashPlayer crash

Expected Results:
No FlashPlayer crash
Comment 14 Karl Tomlinson (back Dec 13 :karlt) 2011-08-09 23:01:09 PDT
Thanks very much, Thomas!
Comment 15 Benoit Girard (:BenWa) 2011-08-09 23:13:22 PDT
Thanks for finding the regression range! The problem is here:
http://hg.mozilla.org/mozilla-central/rev/5cea57e451dd#l6.228

I will post a patch first thing in the morning and will spin off a try build.
Comment 16 Benoit Girard (:BenWa) 2011-08-10 07:14:36 PDT
Created attachment 552071 [details] [diff] [review]
patch v1

See: http://hg.mozilla.org/mozilla-central/rev/5cea57e451dd#l6.228
This line was not meant to be changed for non osx platforms.
Comment 17 Benoit Girard (:BenWa) 2011-08-10 07:17:27 PDT
Try run: http://tbpl.mozilla.org/?tree=Try&rev=92f1de674411
Comment 18 Benoit Girard (:BenWa) 2011-08-10 11:50:27 PDT
Can someone confirm that the problem is fixed before we land this?

Try builds:
https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/b56girard@gmail.com-92f1de674411/
Comment 19 Thomas Ahlblom 2011-08-10 12:04:56 PDT
I've tested https://ftp.mozilla.org/pub/mozilla.org/firefox/try-builds/b56girard@gmail.com-92f1de674411/try-linux64/firefox-8.0a1.en-US.linux-x86_64.tar.bz2 together with the STR from comment 13 and have NOT been able to reproduce the bug. Thus, it looks fixed to me.
Comment 21 Mounir Lamouri (:mounir) 2011-08-11 04:37:22 PDT
Merged:
http://hg.mozilla.org/mozilla-central/rev/0e60623e3607
Comment 22 Sheila Mooney 2011-08-25 14:48:47 PDT
So technically we still see this crash in recent builds but the volume is way down. I don't see a reason to track this.

+ 9.0a1 - 7 crashes in the past 2 weeks.
+ 8.0a2 - 3 crashes in the past 2 weeks.
Comment 23 Robert Kaiser 2011-08-26 04:43:11 PDT
(In reply to Sheila Mooney from comment #22)
> So technically we still see this crash in recent builds but the volume is
> way down. I don't see a reason to track this.

Yes, the fix landed for 8, so we should be OK. The remaining ones are probably not this regression at least (or it's old builds).

Note You need to log in before you can comment on or make changes to this bug.