Visited link doesn't change color if server has capital letters

RESOLVED DUPLICATE of bug 12493

Status

--
minor
RESOLVED DUPLICATE of bug 12493
18 years ago
14 years ago

People

(Reporter: steven.chapel, Assigned: asa)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
Reproducability: Always

Steps to reproduce:
1. Click on a link that has capital letters in the server name (the provided URL
will work).
2. Click on the back button.

Expected Results: the visited link will change to the visited color
Actual Results: the visited link remains in the unvisited color

If you change the URL in the link to have all lowercase letters in the server
name, the link suddenly changes color. This indicates that the link was stored
in the history, but as lowercase. The string comparison between visited links
and available links should be case insensitive in the server name.

Comment 1

18 years ago
dupe of nightmare bug 12493. dns is now unicode, i don't know if non ascii 
portions are case insensitive.

*** This bug has been marked as a duplicate of 12493 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.