Problem: View multiple large attachments inline = slow, freezing. Request: display a few inline at first and more only on scroll to bottom

RESOLVED DUPLICATE of bug 337393

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 337393
7 years ago
7 years ago

People

(Reporter: Dionia, Unassigned)

Tracking

({perf})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Get email with multiple large images attached (in total over 10MB) and have "view > display attachments inline" activated.


Actual results:

When selecting that email Thunderbird freezes several seconds while loading all the images inline.



Expected results:

Thunderbird should check if an email has multiple large size attachments that can be displayed inline. If so then Thunderbird should display the first two images inline. If the user scrolls almost to the bottom of the window then Thunderbird should fill with additional images. Either all remaining on first bottom scroll or (preferred!) some images on each bottom scroll.

Reasoning: to fill/expand display of images on bottom scroll is a very useful feature in many applications and websites. It gives a smoother user experience. Example: Google Image search, http://www.google.com/search?tbm=isch&q=peace

Turning off "view > display attachments inline" prevents the freeze problem but then not even small, single image attachments are displayed. The requested feature would provide an better intermediate alternative.
(Reporter)

Comment 1

7 years ago
Addition: an alternative, less demanding new feature would be to add a sub-option to "view attachments inline" where the user can set an upper size limit. If the total size of attachments eligible for inline view are over the limit then nothing is displayed inline for that email. 

Thunderbird already calculates the size of the attachments and investigates what attachments it can display inline. So maybe not much new code is required for this alternative.
Keywords: perf

Updated

7 years ago
Component: General → Message Reader UI
QA Contact: general → message-reader
Whiteboard: dupeme

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme
Duplicate of bug: 337393
You need to log in before you can comment on or make changes to this bug.