Clear Recent History should be processed in the background

RESOLVED DUPLICATE of bug 648232

Status

()

RESOLVED DUPLICATE of bug 648232
7 years ago
7 years ago

People

(Reporter: claritise, Unassigned)

Tracking

8 Branch
All
Other
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110717 Firefox/8.0a1
Build ID: 20110717040202

Steps to reproduce:

When you want to clear recent history on a older computer periodically (say every 5 months), upon clicking "Clear Now" the dialog just hangs/freezes while it processes your request until it's done which sometimes can take quite a while.



Expected results:

In IE9, maybe some other browsers as well. Upon clicking to clear recent history, it processes in the background and gives a notification upon completion.
Does it change anything if you uncheck cookies from the dialog? Clearing cookies will spawn a new process for each plug-in you have in your profile, and that's going to be slow.

Updated

7 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 648232
You need to log in before you can comment on or make changes to this bug.