When zoomed in, strange artifacts appear on underlined text

RESOLVED DUPLICATE of bug 660189

Status

()

RESOLVED DUPLICATE of bug 660189
7 years ago
7 years ago

People

(Reporter: scook0+bugzilla, Unassigned)

Tracking

({testcase})

Trunk
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

Go to http://www.mozilla.com/en-US/firefox/5.0.1/whatsnew/ . Reset zoom, and then zoom once or twice. Look at the "Get answers" link.


Actual results:

Light-grey segments appear on top of the black underline, breaking it up.


Expected results:

The text and its underline should increase in size without introducing any artifacts.
(Reporter)

Comment 1

7 years ago
Created attachment 546475 [details]
Screenshot of the glitch
(Reporter)

Comment 2

7 years ago
Possibly a duplicate of bug 505243, but it's hard to tell because I can't reproduce the glitch on that bug's test page.

In either case, this does seem to be caused by text-shadow. The glitched parts of the underline align with the letters, and disabling text-shadow in Firebug caused the glitch to disappear.

Comment 3

7 years ago
Reproduced (but I at least sometimes have to zoom more than just one two steps):
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.2.18) Gecko/20110614 Firefox/3.6.18
Mozilla/5.0 (X11; Linux x86_64; rv:5.0) Gecko/20100101 Firefox/5.0
Mozilla/5.0 (X11; Linux x86_64; rv:6.0) Gecko/20100101 Firefox/6.0
Mozilla/5.0 (X11; Linux x86_64; rv:7.0a2) Gecko/20110717 Firefox/7.0a2
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110717 Firefox/8.0a1
OS: Other → All

Comment 4

7 years ago
Yes, it looks as though the white text "shadow" is overlapping the black underline.
Version: 5 Branch → Trunk

Updated

7 years ago
Component: General → Layout: Text
Keywords: testcase-wanted
Product: Firefox → Core
QA Contact: general → layout.fonts-and-text
(Reporter)

Comment 5

7 years ago
Created attachment 546714 [details]
Minimal test page
(Reporter)

Updated

7 years ago
Attachment #546714 - Attachment mime type: text/plain → text/html
(Reporter)

Comment 6

7 years ago
Created attachment 546716 [details]
Screenshot of test page at +1 zoom

Updated

7 years ago
Keywords: testcase-wanted → testcase

Comment 7

7 years ago
WFM on Mozilla/5.0 (Windows NT 6.1; rv:8.0a1) Gecko/20110802 Firefox/8.0a1
There is no glitch.

Reproducible for me on Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:8.0a1) Gecko/20110802 Firefox/8.0a1

Setting resolution to NEW.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Created attachment 550070 [details]
The testcase zoomed up on Linux

Comment 9

7 years ago
Isn't this a duplicate of Bug 660189?
Yes, I agree.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 660189
You need to log in before you can comment on or make changes to this bug.