Flash video stops updating while browser page is resized

REOPENED
Unassigned

Status

()

Core
Plug-ins
REOPENED
6 years ago
4 years ago

People

(Reporter: George Carstoiu, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:6.0) Gecko/20100101 Firefox/6.0

Going to the following website: http://www.communitymx.com/content/source/E5141/wmode.swf and resizing window, freezes the flash.

Litmus testcase: https://litmus.mozilla.org/show_test.cgi?id=24514

Steps to reproduce:
1. Load http://www.communitymx.com/content/source/E5141/wmode.swf
2. Resize the window.

Actual results:
 - flash freezes while window is resized
 
Expected results:
 - After Step 2 you should be able to successfully resize the window without a crash or any other issues.

Shockwave Flash

    File: Flash Player.plugin
    Version: 10.3.181.34
    Shockwave Flash 10.3 r181
This bug report is far too vague.  What do you mean by "freeze"?

And the problems I was able to find (using your testcase) don't just
happen on OS X 10.7.  In the future please test on other versions of
OS X before reporting that some bug is specific to a particular
version.

With the default settings (basically using a clean profile), the only
problem I saw was that the testcase stopped updating while the page
was being resized.  It started updating again as soon as you finished
resizing, and there was definitely no "freeze" or hang or crash (the
plugin-container process was not restarted).

This is a bug, I suppose, but a pretty minor one.  I see it on OS X
10.7, 10.6 and 10.5, in all FF versions that I tested (back to FF
3.6.18).  I also see it to a lesser extent in Chrome (on OS X 10.6.8).
In all cases I tested with the latest version of the Flash plugin --
10.3.181.34.

The only serious problem I saw (the only one resembling a temporary
hang or freeze) was with non-default settings, and only happened back
to FF 4.0 (i.e. not with FF 3.6.18), and back to OS X 10.6 (i.e. not
with OS X 10.5.8).  Here's how to reproduce it:

1) In about:config, set dom.ipc.plugins.enabled.i386.flash
   player.plugin to 'false'.  This forces the Flash plugin to run in
   process (if the browser is in 32-bit mode).

2) Quit FF, right click on the FF distro, and do the following:

   a) Choose "Get Info".
   b) Select "Open in 32-bit mode".

3) Start FF, load this bug's testcase
   (http://www.communitymx.com/content/source/E5141/wmode.swf), and
   start resizing it.

   Notice that resizing performance slows to a crawl, and that there
   are display artifacts (among other things, the browser window goes
   completely white for a few seconds).  These clear up a few seconds
   after you stop resizing.

   Not quite a hang or a freeze, but something close to it.  However,
   I never saw the plugin-container process crash.
Summary: Flash freezes during window resize on Mac OS X 10.7 → Bad behavior resizing animated Flash plugin while running in-process
Benoit, do you have any idea what could be causing the semi-hang I report in comment #1?
Version: 6 Branch → unspecified
> 1) In about:config, set dom.ipc.plugins.enabled.i386.flash
>    player.plugin to 'false'.  This forces the Flash plugin to run in
>    process (if the browser is in 32-bit mode).
> 
Even when running the browser in 32-bit mode, flash will run out of process. I'm curious why we are concerned about supporting this old, non default, code path?

>    Notice that resizing performance slows to a crawl, and that there
>    are display artifacts (among other things, the browser window goes
>    completely white for a few seconds).  These clear up a few seconds
>    after you stop resizing.
> 
>    Not quite a hang or a freeze, but something close to it.  However,
>    I never saw the plugin-container process crash.

This code path is very outdated and amongst other things doesn't use plugin layers, async rendering. It's likely that there's been regression with this code path since I don't think anyone is running it.

If we have a good reason to support this code path then I'm willing to take some time this week to investigate.
> Even when running the browser in 32-bit mode, flash will run out of process.

Not if you set dom.ipc.plugins.enabled.i386.flash player.plugin to 'false'.

> If we have a good reason to support this code path then I'm willing
> to take some time this week to investigate.

We *don't* have any good reason to support it, as far as I'm
concerned.  I was just curious if you knew, off the top	of your head,
why the "semi-hang" happens.  (Perhaps I should	have made this
clearer.)

Apparently you don't, and I think we can let the matter rest there.

So I'll mark this bug WONTFIX.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 5

6 years ago
Still, I think you should reconsider changing the status of this issue. I tested the same issue (the hang while resizing) on Safari and it is not reproducible.

Maybe we should relate to Safari when it comes to Mac OS and not Opera or Chrome.
With a default installation (Nightly), the problem I see here is that the video playback, in youtube, jitters when I resize the Firefox window. Sound keeps going.

If I stop resizing, but I don't let go of the resize handle in the lower right-hand corner, the video stops.

If I let it go, then the video resumes playing normally.

It feels ugly.

This doesn't happen with with Chrome, nor with Safari. Video playback is smooth while you resize.

I'm reopening so other people can give it a second look.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
I have a patch in bug 663259 that hasn't landed yet. I wanted to give a few days for async plugin to be tested before changing the resize behavior. I hope this land this shortly, perhaps you can give me feedback if this improves the resize behavior for you once it lands.
Juan, what you report isn't either of the two problems I found (and reported in comment #1).  Please open a new bug.  And when you do, be sure to include at least one example, together with detailed instructions on how to reproduce.

As for the original report, it's too vague to tell whether or not it's the same as your bug or either of my two bugs.
(Reporter)

Comment 9

6 years ago
> As for the original report, it's too vague to tell whether or not it's the
> same as your bug or either of my two bugs.

Just so as to clarify this. In Comment 0 I was referring exactly to what Juan saw when he tried to reproduce it - while a video is playing and a user is resizing the window, the video hangs although the sound keeps going. For the average Mac user that is used to everything running smoothly this could be a bit of a hiccup. Also on Windows or Linux builds, this does not happen. so why should it on Mac?
(In reply to comment #9)

You're using the words "hang" and "freeze" in ways they're not
normally used.  I suspect what you really mean to say is that a Flash
video (or your animated example) stops updating (or updates only
intermittently) while the page is being resized.  If so, then your bug
is the first of the two I described in comment #1.

Juan's report is (frankly) not terribly clear, either -- what is the
"jittering" that he reports?  But I suspect he's also seeing the
"Flash video not updating while the page is resized" problem.

If so, we actually have something to work with, and I'll repurpose the
bug.

As I said in comment #1, I found the "not updating while resizing"
problem back to OS X 10.5.8, and in the oldest version of Firefox that
I tested (3.6.18).

I realize it may not be possible for you to test on other versions of
OS X.  But it's easy to download and test with older Firefox versions.
So please test to see if *your* bug happens back to FF 3.6.18 (or
3.5.19).
Summary: Bad behavior resizing animated Flash plugin while running in-process → Flash video stops updating while browser page is resized
Another thing:  Please test with older versions of the Flash plugin.  It's possible that this is at least partly a Flash bug, and might not happen with older versions of Flash.
Older versions of the Flash plugin are available at:
http://kb2.adobe.com/cps/142/tn_14266.html
You need to log in before you can comment on or make changes to this bug.