Don't focus fields and activate keyboard for username/password prompt that's already filled in

VERIFIED FIXED in Firefox 8

Status

Firefox for Android Graveyard
General
--
minor
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: mbrubeck, Assigned: mbrubeck)

Tracking

({polish})

Trunk
Firefox 8
polish

Details

(Whiteboard: [vkb][has patch][inbound])

Attachments

(1 attachment)

(Assignee)

Description

7 years ago
Created attachment 546553 [details] [diff] [review]
patch

Steps to reproduce:
1. Open Fennec on a device with an on-screen keyboard.
2. Open a web page that requires HTTP authentication, like https://intranet.mozilla.org
3. If you don't have a login already saved for the page, enter your login information and ask the browser to save it, then exit the browser and repeat steps 1 and 2.

Actual results: The HTTP auth prompt appears with the username and password already filled in. Then the on-screen keyboard appears, and the prompt moves suddenly as the window resizes.

Expected results: The HTTP auth prompt appears with the username and password already filled in, but the on-screen keyboard does not appear and the prompt remains in one place.

This is just a simple polish issue, but it became a pet peeve when I spent a lot of time recently accessing HTTP auth sites in Fennec.  The prompt often moves right as I am trying to press a button, and I end up tapping in the wrong place.  It also looks jerky and bad.  This patch just prevents us from focusing the username field if it is already pre-filled.
Attachment #546553 - Flags: review?(mark.finkle)
Comment on attachment 546553 [details] [diff] [review]
patch

It might make more sense to not ever "focus" dialogs with a VKB. This is a good start.

I wonder  how hard it would be to determine the hard keyboard vs VKB
Attachment #546553 - Flags: review?(mark.finkle) → review+
(Assignee)

Comment 2

7 years ago
http://hg.mozilla.org/integration/mozilla-inbound/rev/6002cc2f9b2b
Whiteboard: [vkb][has patch] → [vkb][has patch][inbound]
http://hg.mozilla.org/mozilla-central/rev/6002cc2f9b2b
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 8
It works fine with the steps from comment #0 on the latest Aurora build.

Verified fixed on:
Mozilla/5.0 (Android;Linux armv7l;rv:8.0a1)Gecko/20110901
Firefox/8.0a1 Fennec/8.0a1
Device: Samsung Galaxy S
OS: Android 2.2
Status: RESOLVED → VERIFIED
Duplicate of this bug: 685103
You need to log in before you can comment on or make changes to this bug.