almost no events displayed in trunk Calendar

RESOLVED WORKSFORME

Status

Calendar
Calendar Views
--
major
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: tonymec, Unassigned)

Tracking

({regression, useless-UI})

Trunk
x86_64
Linux
regression, useless-UI

Details

* Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110718 Firefox/8.0a1 SeaMonkey/2.5a1 ID:20110718003016
  lightning.xpi (hourly 1310942243) datestamped 2011-07-17 15:42 on FTP server (last linux64 build before all tinderboxes went up in flames)
  - all my calendars (file: and http: URLs) are ICS except one remote Google; no "storage" calendar
  - no events displayed except for the single "cached" calendar (Belgian public holidays from Mozilla)
  - events list status (above the grid) is "don't know": I closed it by mistake some days ago and now I can't find how to reopen it
  - switching day <=> week <=> multiweek <=> month is OK except empty
  - when I set everything to cached and restarted SeaMonkey, even the few displayed events disappeared
  - everything is dispayed OK in obsolete Sunbird 1.0b2pre (build ID 20100526025912)

Problem didn't happen with SeaMonkey and Lightning nightlies dated 2011-07-17

I'll check this again when the builders go back to green.
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110719 Firefox/8.0a1 SeaMonkey/2.5a1 ID:20110719003019

Hm. With the same Lightning hourly and the next SeaMonkey nightly, no error.

This time I had opened the calendar tab after the mailer had finished polling my mail/news/feed servers, after ChatZilla had run its startup auto-connects and auto-joins, and before clicking the browser's Home button to load my 148-tab homepage (I have set it up to load a blank page in all three of "at startup", "new window" and "new tab").

Maybe a sporadic race condition? If you don't mind, Philipp, I won't close this WFM yet.
Mozilla/5.0 (X11; Linux x86_64; rv:8.0a1) Gecko/20110721 Firefox/8.0a1 SeaMonkey/2.5a1 ID:20110721003056

Looks like a one-time thing.

With such a rare sporadic bug, I suppose we don't even have enough data for an educated guess at where in the source the bug might be.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.