Closed Bug 672286 Opened 9 years ago Closed 8 years ago

Copy xpcshell.ini only if ENABLE_TESTS is set

Categories

(MailNews Core :: Build Config, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 8.0

People

(Reporter: t.matsuu, Assigned: t.matsuu)

References

Details

Attachments

(3 files, 1 obsolete file)

We should ensure to exist the directory $(MOZDEPTH)/_tests/xpcshell.

In some situation, $(MOZDEPTH)/_tests/xpcshell does not exist now.
ie. --enable-system-hunspell after http://hg.mozilla.org/mozilla-central/rev/8e5f130a6640

So $(MOZDEPTH)/_tests/xpcshell should be prepared prior to copy $(MOZILLA_SRCDIR)/testing/xpcshell/xpcshell.ini to $(MOZDEPTH)/_tests/xpcshell/xpcshell-core.ini.
Attachment #546577 - Flags: review?(mbanner)
Attachment #546577 - Flags: review?(mbanner) → review?(bugspam.Callek)
Comment on attachment 546577 [details] [diff] [review]
Ensure to exist $(MOZDEPTH)/_tests/xpcshell

I'm a little confused on how a change for hunspell enable/disable would cause this dir not to exist, also if it doesn't exist why we would want to copy anything to it in the first place (to hack around other issues)...

That said I could just be being dense, so punting review to Mark. ... Mark if this patch also needs to be in suite/ (if it is indeed needed) can we be sure to make that happen?
Attachment #546577 - Flags: review?(bugspam.Callek) → review?(mbanner)
Attached file my mozconfig
c-c:592a6c14182d with m-c:4274ccb37cf6 is successfully build. However c-c:3d95e40b74f2 with m-c:a0372b031aac failed without the patch.

The only change between the builds is the source tarball.
mozconfig is not changed.

According to the build log, c-c:592a6c14182d generates mozilla/_tests/xpcshell/extensions/spellcheck/hunspell/tests/unit/data directory and it's the only process to generate _tests/xpcshell directory. However c-c:3d95e40b74f2 don't generate mozilla/_tests/xpcshell directory during the build.
Now I understand that we copied xpcshell.ini anytime. If --disable-tests is set, we don't need to copy it.
Attachment #546577 - Attachment is obsolete: true
Attachment #546724 - Flags: review?(mbanner)
Attachment #546577 - Flags: review?(mbanner)
Duplicate of this bug: 672461
Attachment #546724 - Attachment description: Ensure to exist $(MOZDEPTH)/_tests/xpcshell, v2 → copy xpcshell.ini only if ENABLE_TESTS is set. And ensure to exist $(MOZDEPTH)/_tests/xpcshell, v2
Summary: Ensure to exist $(MOZDEPTH)/_tests/xpcshell → Copy xpcshell.ini only if ENABLE_TESTS is set
Attachment #546724 - Flags: review?(mbanner) → review+
Attachment #546745 - Flags: review?(mbanner) → review+
Keywords: checkin-needed
Assignee: nobody → t.matsuu
Checked in: http://hg.mozilla.org/comm-central/rev/6d8318b1709e
Status: NEW → RESOLVED
Closed: 8 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 8.0
Flags: in-testsuite-
You need to log in before you can comment on or make changes to this bug.