Adjust developer tools to accept a manifest URL

RESOLVED FIXED in 6.2.2

Status

P1
normal
RESOLVED FIXED
7 years ago
3 years ago

People

(Reporter: clouserw, Assigned: kumar)

Tracking

unspecified
6.2.2
Dependency tree / graph

Details

(Reporter)

Description

7 years ago
We want to change the developer tools upload process to accept a manifest.  So, that's basically adjusting this page (https://addons.allizom.org/en-US/developers/addon/submit/2) to accept a URL of a manifest[1] and then parsing out all the juicy stuff (name/description/etc.).  There will be other juicy stuff which we might need to store, but let's start with what lines up with add-ons  (we should grab the icons too!).

Piotr has some code from flightdeck that passes in the right flags to urllib2 that won't bring down the box if I pass in a 1G file.  We should copy that.


[1] https://developer.mozilla.org/en/OpenWebApps/The_Manifest
(Reporter)

Updated

7 years ago
Depends on: 672338
(Reporter)

Updated

7 years ago
Target Milestone: 6.1.7 → 6.1.8
(Reporter)

Updated

7 years ago
Target Milestone: 6.1.8 → 6.1.9
Depends on: 676116
Depends on: 676119
Depends on: 676120
(Reporter)

Updated

7 years ago
Target Milestone: 6.1.9 → Q3 2011
(Reporter)

Updated

7 years ago
Target Milestone: Q3 2011 → 6.2.2

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676119
This was just a tracking bug that got split up into more detailed user stories. Since all dependency bugs are now fixed I'm setting this to fixed (not duped) to avoid confusion.
Resolution: DUPLICATE → FIXED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.