Closed Bug 672486 Opened 9 years ago Closed 6 years ago

IBM Websphere Portal 7.0 missing page editing function under action menu

Categories

(Web Compatibility :: Desktop, defect)

All
Other
defect
Not set

Tracking

(Not tracked)

RESOLVED INVALID

People

(Reporter: andrew, Unassigned)

Details

(Whiteboard: [remote xul])

Attachments

(1 file)

Attached image ffbug_image.JPG
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1
Build ID: 20110707182747

Steps to reproduce:

1. Install IBM Websphere Portal 7.0.0.1
2. Login to the Admin page on port 10029:
  https://localhost:10029/wps/portal
3. Click on the "Action" menu button whiting the portal page.
4. This action will provide a pull-down menu for portal page editing.
5. In FF 4 and FF5 a number of menu options are missing.
(Sample of the output is captured in the attached image)


Actual results:

Due to this issue editing a portal page is not possible.
Have to revert to Microsoft IE or Firefox 3.5


Expected results:

Expecting a full pull-down menu for this WebSphere application
/s/menu button whiting the portal page/menu button within the portal page
Maybe it's just bogus UA sniffing in Websphere?
Does it work if you use a fake UA string?
By UA you mean user-agent, than yes, I've tried changing to IE6 or IE7, but the results are the same.
Have to revert to Microsoft IE or Firefox 3.5
....
>I've tried changing to IE6 or IE7, but the results are the same.
Wouldn't it be more logical to try the Firefox 3.5 UA ?
Did that work in Firefox3.6 ?

Note: The UA between FF3.x and FF4.0 changed (no, i don't mean the version number)
Yes it is working in 3.6. 
I've tried UA 3.5.5 with 4.0 but the problem persists.
Are there any error messages in the Error Console? (in Firefox Tools menu)
Below is the error. A green arrow is pointing to the letter "x" <xul:popup>


Error: 
Source File: https://portal.mydomain.com/wps/mycontenthandler/!ut/p/digest!XUoQlh4Iet9VNgpQEhLZhw/wp.operations/page:oid:Z6_J000BB1A0OFB40I191I45930K2
Line: 1, Column: 127
Source Code:
<?xml version="1.0" encoding="UTF-8"?><xul:popupset xmlns:xul="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"><xul:popup><xul:menuitem title="New Page" label="CreatePage" safe="true" oncommand="onCreatePage(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Edit Page Layout" label="EditLayout" safe="true" oncommand="onEditLayout(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Edit Page Properties" label="EditPageProperties" safe="true" oncommand="onEditPageProperties(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Assign Page Permissions" label="AssignRoles" safe="true" oncommand="onAssignRoles(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Delete Page" label="DeletePage" safe="false" oncommand="onDeletePage(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Tag this Page" label="tagPage" safe="false" oncommand="onPageLaunchTagWidget(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Rate this Page" label="ratePage" safe="false" oncommand="onPageLaunchRateWidget(Z6_J000BB1A0OFB40I191I45930K2)"/><xul:menuitem title="Browse Tags" label="browseTagsPage" safe="false" oncommand="onPageBrowseTags(Z6_J000BB1A0OFB40I191I45930K2)"/></xul:popup></xul:popupset>
Remote XUL is no longer supported as of Firefox 4.
There is however a whitelist so you can enable it on a per domain basis.
There is an add-on to help you manage that list:
https://addons.mozilla.org/en-US/firefox/addon/remote-xul-manager/
Andrew, please report this problem to IBM.
Assignee: nobody → english-us
Component: General → English US
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Whiteboard: [remote xul]
Version: 5 Branch → unspecified
Confirmed, the add-on works as it should.
When remote XUL is enabled for domain the pull-down menus function as on FF3.X

Mats, thanks for your input, I'll submit a PMR to IBM with regards to this issue and will reference this bug report.

A.
It has probably been solved by now.
Reopen if the issue persists.

As for WebSphere 
http://www-03.ibm.com/software/products/en/portalserver
They seem to be at version 8.5

As for support of Firefox by IBM the policy is expressed here
http://www-01.ibm.com/support/docview.wss?uid=swg21580984


resolving as INVALID, because the product has certainly changed.
Assignee: english-us → nobody
Status: UNCONFIRMED → RESOLVED
Closed: 6 years ago
Component: English US → Desktop
Resolution: --- → INVALID
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.