If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

"-->" in the middle of page elements

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Ryan McLoughlin, Assigned: karnaze (gone))

Tracking

Trunk
x86
Windows 95
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; m18) Gecko/20010126
BuildID:    20010126

Below the green "Welcome to Fleet Homelink" banner on the left side of the page
there are three characters "-->" which shouldn't be there.  The "-->" and the
entire white line they're on are shown neither in Netscape 4.08 nor in IE 4.72.

Reproducible: Always
Steps to Reproduce:
1. Load the URL

Expected Results:  The "-->" and the line it's on should not be there

Comment 1

17 years ago
Created attachment 24051 [details]
The file from where the --> show up

Comment 2

17 years ago
Here's a snap of that page:

</style> this tag shouldn't be here at all (this breaks comment)

--> <<<<<<<<<<<<<<<<<<<< so this will show up
</style>

So not a bug in Mozilla, but rather in the page. 
And who will be the invalidator this time?

Comment 3

17 years ago
hmm...
H-J : you're right it's an error in the page... but it's inside the style tag...
i'm not sure if it should be displayed or not...

Comment 4

17 years ago
Yes, but the comment tags are broken by the first <style> tag! Remember it goes
like this:

<script>
<!--
</script>
-->
</script>

Note, I always use //--> instead of -->

Comment 5

17 years ago
H-J: you're right. i have n0t seen that.
in this case i would say: mozilla does it right.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.