Update bugzilla-agile to work with Firefox 6

VERIFIED FIXED in 1.0

Status

P2
normal
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: openjck, Assigned: groovecoder)

Tracking

unspecified

Details

(Whiteboard: u=team c=infrastructure p=1)

Comment hidden (empty)
(Assignee)

Comment 1

8 years ago
It should work if you compile it yourself?

https://github.com/groovecoder/BugzillaJS/blob/master/README#L16
(Assignee)

Comment 2

8 years ago
I just confirmed - if you follow the compile instructions it will work for any version.

Greg, want to make another release of BugzillaJS? I'll send you a pull request ...
(Assignee)

Updated

8 years ago
Whiteboard: u=team member c=infrastructure p= → u=team member c=infrastructure p=1
Definitely send me a pull request :)

I should look more into how Jetpacks handle upgrades-- it's always just worked for me (and amo takes care of keeping it updated), so I don't worry too much about it.
(Reporter)

Updated

8 years ago
Priority: -- → P2
Version: Kuma → unspecified
(Assignee)

Comment 4

8 years ago
I think I'll try to do a pull request during this next sprint so that anyone and everyone (esp. devengage) can see our mdn sprint status.
Target Milestone: --- → 1.0
(Assignee)

Updated

8 years ago
Whiteboard: u=team member c=infrastructure p=1 → u=team c=infrastructure p=1
(Assignee)

Comment 5

7 years ago
AFAICT, the addon works in any version of Firefox. (Of course I didn't screenshot fx6!)

http://screencast.com/t/BUZ2AfuY8dxf
http://screencast.com/t/L82xOhec
http://screencast.com/t/jaIzx6IcfxJu

Sent a pull request to greg: https://github.com/gkoberger/BugzillaJS/pull/35 so this can make its way to AMO. 

John, until this hits AMO use the .xpi download on my github fork:

https://github.com/groovecoder/BugzillaJS/downloads

Mark this bug verified fixed if it works for you, or re-open if it doesn't.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

7 years ago
It looks like the xpi doesn't work with Firefox 6, but I'm happy to wait for BugzillaJS to pull it in.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 7

7 years ago
d'oh! I know why you're having trouble. do you use the Add-on Compatibility Reporter?

https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/

It will let you run any addon under any version.
(Reporter)

Comment 8

7 years ago
That did it. Thanks a lot, Luke! This looks great.

For future reference, do the following if using Firefox 6 or above:

* Install the Add-on Compatibility Reporter: https://addons.mozilla.org/en-US/firefox/addon/add-on-compatibility-reporter/
* Install the XPI here: https://github.com/groovecoder/BugzillaJS/downloads
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Status: RESOLVED → VERIFIED
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.