Thunderbird is crashing on some newsgroups (nntp) [@ nsMsgKeySet::Output(char**) ]

RESOLVED DUPLICATE of bug 670935

Status

Thunderbird
General
--
critical
RESOLVED DUPLICATE of bug 670935
7 years ago
6 years ago

People

(Reporter: Alexandre Joly, Unassigned)

Tracking

({crash})

All
Windows XP
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0) Gecko/20100101 Firefox/5.0
Build ID: 20110615151330

Steps to reproduce:

Accessing a newsgroup that contains a '&' character in its name makes Thunderbird crash.


Actual results:

Thunderbird is crashing


Expected results:

Thunderbird should open this newsgroup flawlessly
Which news server are you using? ('&' is an illegal character for newsgroups)
(Reporter)

Comment 2

7 years ago
I'm running an antiquated version of NetWin DNEWS (5.7e1)
More info here : http://netwinsite.com/dnews.htm
Is this instance something I can publicly access?

Also, if you are crashing, do you have a crash ID or a backtrace?
(Reporter)

Comment 4

7 years ago
(In reply to comment #3)
> Is this instance something I can publicly access?

Unfortunately not. I can give you a special access if you're willing to go further with this issue.

> Also, if you are crashing, do you have a crash ID or a backtrace?

Crash ID: bp-ad590fef-2a7f-4f07-b4f5-749322110719
Crash Signature: [@ nsMsgKeySet::Output(char**) ]
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: crash

Comment 5

7 years ago
Joshua, the crash now reports as nsMsgKeySet::Output(char**), which makes this a dup of bug 670935  (crash-stats must not have caught up from it's down time last night when we looked at this)
OS: Other → Windows XP
Summary: Thunderbird is crashing on some newsgroups (nntp) → Thunderbird is crashing on some newsgroups (nntp) [@ nsMsgKeySet::Output(char**) ]

Comment 6

6 years ago
bug #694522 about crash like this.

bug continue to exist in last ver 7.0.1 now. Public server on inn : news.kraft-s.ru

Please investigate. If cannot reproduce please request info.

Comment 7

6 years ago
thanks. I just wanted to be sure
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 188243
Duplicate of bug: 670935
You need to log in before you can comment on or make changes to this bug.